summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Config-JSON')
-rw-r--r--dev-perl/Config-JSON/Config-JSON-1.510.0.ebuild31
-rw-r--r--dev-perl/Config-JSON/Config-JSON-1.520.200.ebuild30
-rw-r--r--dev-perl/Config-JSON/Manifest2
-rw-r--r--dev-perl/Config-JSON/metadata.xml9
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-perl/Config-JSON/Config-JSON-1.510.0.ebuild b/dev-perl/Config-JSON/Config-JSON-1.510.0.ebuild
new file mode 100644
index 000000000000..2b17139d16de
--- /dev/null
+++ b/dev-perl/Config-JSON/Config-JSON-1.510.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MODULE_AUTHOR="RIZEN"
+MODULE_VERSION="1.5100"
+inherit perl-module
+
+DESCRIPTION="A JSON based config file system"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Any-Moose-0.130.0
+ >=virtual/perl-File-Temp-0.180.0
+ >=dev-perl/JSON-2.160.0
+ >=virtual/perl-Scalar-List-Utils-1.190.0
+
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.56
+ test? (
+ >=virtual/perl-Test-Simple-0.700.0
+ >=dev-perl/Test-Deep-0.95.0
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Config-JSON/Config-JSON-1.520.200.ebuild b/dev-perl/Config-JSON/Config-JSON-1.520.200.ebuild
new file mode 100644
index 000000000000..4d7972149d7b
--- /dev/null
+++ b/dev-perl/Config-JSON/Config-JSON-1.520.200.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MODULE_AUTHOR=RIZEN
+MODULE_VERSION=1.5202
+inherit perl-module
+
+DESCRIPTION="A JSON based config file system"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-File-Temp-0.180.0
+ >=dev-perl/JSON-2.160.0
+ >=virtual/perl-Scalar-List-Utils-1.190.0
+ dev-perl/Moo
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ >=virtual/perl-Test-Simple-0.700.0
+ >=dev-perl/Test-Deep-0.95.0
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Config-JSON/Manifest b/dev-perl/Config-JSON/Manifest
new file mode 100644
index 000000000000..8278b1ab2b25
--- /dev/null
+++ b/dev-perl/Config-JSON/Manifest
@@ -0,0 +1,2 @@
+DIST Config-JSON-1.5100.tar.gz 18190 SHA256 20deb04a4555fc440566aca58ab88a84cda01bed59ada85fa459aaf1c9370432 SHA512 09de924b251e14e98602dd1db74e09e975b0a6c4d0ddfb9a5ed3d32198f206ad51b79061e6f05122507baab45123379bfb589add17d7f2e0fab16ac71a2ce0f8 WHIRLPOOL 02cad6f48a3df504de08de9a1302537693717ae6edae3761aa34291dc9543913e1604f3e7d41285a7c001f3b0868825e8f90bb4e3e870a8c0c658d5c0ea353b2
+DIST Config-JSON-1.5202.tar.gz 18288 SHA256 fdbd4008ef8fb50b4cf26c6c45cc38c2597ddd54aec3b3145bbabb5cc25af930 SHA512 13821db9318af9b3223e01bc28442a520880a098c333b89a67296fb34979bc0fa9c98a93470a72185e24789c66d607f2c932d6ff4e9a6e407359b86dc1be646f WHIRLPOOL 60c2faaa546cd8acb309c5cfb04c838cae9b497fe1849283d8873ebcf7c09830bfcb7627b8c6b42eef6657394182b0089aa161801bd6c3d9ad997571b3c80232
diff --git a/dev-perl/Config-JSON/metadata.xml b/dev-perl/Config-JSON/metadata.xml
new file mode 100644
index 000000000000..147900e1cdb3
--- /dev/null
+++ b/dev-perl/Config-JSON/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Config-JSON</remote-id>
+ <remote-id type="cpan-module">Config::JSON</remote-id>
+ </upstream>
+</pkgmetadata>