summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/LWP-Protocol-https')
-rw-r--r--dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.30.0-r1.ebuild30
-rw-r--r--dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.60.0.ebuild33
-rw-r--r--dev-perl/LWP-Protocol-https/Manifest3
-rw-r--r--dev-perl/LWP-Protocol-https/files/LWP-Protocol-https-6.60.0-CVE-2014-3230.patch22
-rw-r--r--dev-perl/LWP-Protocol-https/files/LWP-Protocol-https-6.60.0-etcsslcerts.patch33
-rw-r--r--dev-perl/LWP-Protocol-https/metadata.xml10
6 files changed, 131 insertions, 0 deletions
diff --git a/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.30.0-r1.ebuild b/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.30.0-r1.ebuild
new file mode 100644
index 000000000000..bfa9d6f4d6bf
--- /dev/null
+++ b/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.30.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=GAAS
+MODULE_VERSION=6.03
+inherit perl-module
+
+DESCRIPTION="Provide https support for LWP::UserAgent"
+SRC_URI+=" http://dev.gentoo.org/~tove/distfiles/${CATEGORY}/${PN}/${PN}_ca-cert-r1.patch.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ app-misc/ca-certificates
+ >=dev-perl/libwww-perl-6.20.0
+ >=dev-perl/Net-HTTP-6
+ >=dev-perl/IO-Socket-SSL-1.540.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+PATCHES=( "${WORKDIR}"/${PN}_ca-cert-r1.patch )
+
+SRC_TEST=online
diff --git a/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.60.0.ebuild b/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.60.0.ebuild
new file mode 100644
index 000000000000..b4c366e26056
--- /dev/null
+++ b/dev-perl/LWP-Protocol-https/LWP-Protocol-https-6.60.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MSCHILLI
+MODULE_VERSION=6.06
+inherit perl-module
+
+DESCRIPTION="Provide https support for LWP::UserAgent"
+SRC_URI+=" http://dev.gentoo.org/~tove/distfiles/${CATEGORY}/${PN}/${PN}_ca-cert-r1.patch.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ app-misc/ca-certificates
+ >=dev-perl/libwww-perl-6.20.0
+ >=dev-perl/Net-HTTP-6
+ >=dev-perl/IO-Socket-SSL-1.540.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.60.0-etcsslcerts.patch
+ "${FILESDIR}"/${PN}-6.60.0-CVE-2014-3230.patch
+)
+
+SRC_TEST=online
diff --git a/dev-perl/LWP-Protocol-https/Manifest b/dev-perl/LWP-Protocol-https/Manifest
new file mode 100644
index 000000000000..6be59c9da6fc
--- /dev/null
+++ b/dev-perl/LWP-Protocol-https/Manifest
@@ -0,0 +1,3 @@
+DIST LWP-Protocol-https-6.03.tar.gz 3555 SHA256 cb864de7677cc3fc9f8f4aaa17c2984d970fdfa46fc7e3cb90bc5ef2c3e3c6f1 SHA512 531326ba359e242d552f091f270ad4d5b80090093b3b2c89fec5f93f9e7f8807b5db95590f620d026e9090794f3e7775bf27480cba087af170207d99e25e6c14 WHIRLPOOL c0509f659f30c62370bfe3414cfef5e8c06ef653698902291ffa3cefc3623b33c41eb8d78cceda61d93d856df351b143612f145cc7f43ae15f14e64e910638f8
+DIST LWP-Protocol-https-6.06.tar.gz 8376 SHA256 b86c83cc1dcf4a6f84e2fbe32f9c39591a36e6e418af00533505f3452496adef SHA512 acc65d63da858f25cf9cc1e11d074f035e8ead4c1ffea22bac930f61100ff98f2bf0bb4ede12219d6c22bd5fe4d99532a45fe5cbc9a4b863dd16b0c379f8d2ea WHIRLPOOL a7baea45b51a4646ca014eb63684ea21a86d89b53e6ee551276b9b94fe4508b102c20e6e1f5fc6507ccedd1f4fa4cf38888dfb3e68d7982e5c3c1822631f4883
+DIST LWP-Protocol-https_ca-cert-r1.patch.gz 597 SHA256 c8eee81eb55537aa47637b3e218a6c1fec13ca362a9d397b085eb8703fbee851 SHA512 9cc73a042e8c8a9e6bcd377d70978063d3da4c263da35097306b916990845d19580c7cb9fbf7b63efa280366969fcda38a9ac8c2b443891dcf6ac522edab6c0c WHIRLPOOL 743d272adbd4ce461ce50072ba443557a4eb9cf4cf1f0d4d867a19515e4d8bd85bf3bcfa0bd6f1657d758cef3ba24022aafca6cd029d352aa02651f6bdbfc05f
diff --git a/dev-perl/LWP-Protocol-https/files/LWP-Protocol-https-6.60.0-CVE-2014-3230.patch b/dev-perl/LWP-Protocol-https/files/LWP-Protocol-https-6.60.0-CVE-2014-3230.patch
new file mode 100644
index 000000000000..1eb26d2e4092
--- /dev/null
+++ b/dev-perl/LWP-Protocol-https/files/LWP-Protocol-https-6.60.0-CVE-2014-3230.patch
@@ -0,0 +1,22 @@
+Source: https://bugzilla.redhat.com/show_bug.cgi?id=1094440
+
+This patch combines the following two:
+https://bugzilla.redhat.com/attachment.cgi?id=894747
+https://bugzilla.redhat.com/attachment.cgi?id=894748
+
+diff -ruN LWP-Protocol-https-6.06.orig/lib/LWP/Protocol/https.pm LWP-Protocol-https-6.06/lib/LWP/Protocol/https.pm
+--- LWP-Protocol-https-6.06.orig/lib/LWP/Protocol/https.pm 2014-04-18 18:33:26.000000000 +0200
++++ LWP-Protocol-https-6.06/lib/LWP/Protocol/https.pm 2014-10-26 23:57:27.714303175 +0100
+@@ -21,7 +21,11 @@
+ $ssl_opts{SSL_verifycn_scheme} = 'www';
+ }
+ else {
+- $ssl_opts{SSL_verify_mode} = 0;
++ if ( $Net::HTTPS::SSL_SOCKET_CLASS eq 'Net::SSL' ) {
++ $ssl_opts{SSL_verifycn_scheme} = '';
++ } else {
++ $ssl_opts{SSL_verifycn_scheme} = 'none';
++ }
+ }
+ if ($ssl_opts{SSL_verify_mode}) {
+ unless (exists $ssl_opts{SSL_ca_file} || exists $ssl_opts{SSL_ca_path}) {
diff --git a/dev-perl/LWP-Protocol-https/files/LWP-Protocol-https-6.60.0-etcsslcerts.patch b/dev-perl/LWP-Protocol-https/files/LWP-Protocol-https-6.60.0-etcsslcerts.patch
new file mode 100644
index 000000000000..55163a097835
--- /dev/null
+++ b/dev-perl/LWP-Protocol-https/files/LWP-Protocol-https-6.60.0-etcsslcerts.patch
@@ -0,0 +1,33 @@
+See https://bugs.gentoo.org/358081
+
+
+diff -ruN LWP-Protocol-https-6.06.orig/lib/LWP/Protocol/https.pm LWP-Protocol-https-6.06/lib/LWP/Protocol/https.pm
+--- LWP-Protocol-https-6.06.orig/lib/LWP/Protocol/https.pm 2014-04-18 18:33:26.000000000 +0200
++++ LWP-Protocol-https-6.06/lib/LWP/Protocol/https.pm 2014-10-27 00:04:50.604802937 +0100
+@@ -25,25 +25,7 @@
+ }
+ if ($ssl_opts{SSL_verify_mode}) {
+ unless (exists $ssl_opts{SSL_ca_file} || exists $ssl_opts{SSL_ca_path}) {
+- eval {
+- require Mozilla::CA;
+- };
+- if ($@) {
+- if ($@ =! /^Can't locate Mozilla\/CA\.pm/) {
+- $@ = <<'EOT';
+-Can't verify SSL peers without knowing which Certificate Authorities to trust
+-
+-This problem can be fixed by either setting the PERL_LWP_SSL_CA_FILE
+-environment variable or by installing the Mozilla::CA module.
+-
+-To disable verification of SSL peers set the PERL_LWP_SSL_VERIFY_HOSTNAME
+-environment variable to 0. If you do this you can't be sure that you
+-communicate with the expected peer.
+-EOT
+- }
+- die $@;
+- }
+- $ssl_opts{SSL_ca_file} = Mozilla::CA::SSL_ca_file();
++ $ssl_opts{SSL_ca_path} = '/etc/ssl/certs';
+ }
+ }
+ $self->{ssl_opts} = \%ssl_opts;
diff --git a/dev-perl/LWP-Protocol-https/metadata.xml b/dev-perl/LWP-Protocol-https/metadata.xml
new file mode 100644
index 000000000000..4a0ec0000a27
--- /dev/null
+++ b/dev-perl/LWP-Protocol-https/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">LWP-Protocol-https</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::https</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol::https::Socket</remote-id>
+ </upstream>
+</pkgmetadata>