summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/async-timeout')
-rw-r--r--dev-python/async-timeout/Manifest1
-rw-r--r--dev-python/async-timeout/async-timeout-5.0.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/async-timeout/Manifest b/dev-python/async-timeout/Manifest
index b48bc39ab4ae..0e272d7787c7 100644
--- a/dev-python/async-timeout/Manifest
+++ b/dev-python/async-timeout/Manifest
@@ -1,2 +1,3 @@
DIST async-timeout-4.0.3.tar.gz 8345 BLAKE2B cd603b5b58f85412220a99b7b5001ac08df18239f8fca0bf20648f1af982a5dd51b7d84ccce1d168530ee1c1afcef048e03b3de68ba8db068782f79da28bfddd SHA512 d7628370c47587a64170e067a5341bba17658da10900fb8ddf4426aa3f4facc55d63b28febb4b65abe12a9ff5be759319f49fc723c82a5a6cc27377c5e33a5a0
DIST async_timeout-5.0.0.tar.gz 8951 BLAKE2B 6af85e8892eeeff5fb6fe0c000fb2a053bbcd8a3d5221b0fe90fbced50cfa257c09d229182b9f55c78f60a542e7570fe174b8c8248444dea36983483a5df5813 SHA512 542ed0d38e8e46140e4b7cd345c5dbd30112bd12f4e7de4c38784bcb7ba810bf10e9d6a9c16dadb2ce919954084164ec299f7b59eddc676cf29c46299e3259bd
+DIST async_timeout-5.0.1.tar.gz 9274 BLAKE2B cfc1d36d6627351308b91bc6c08030d1a9dbb9e09373bd13bc942884c6e5f7624aff30140d80c64cd9e99a4fd9ceb0cbdf8d5c14bb15c9b7615da9485d165520 SHA512 cf82de33bf4e092e8b092d9fdd18260ee708383940f3bb198bbad9ee137aa7573e511aaf2bc29f6c19c341c8e66abb6b8c4d5c0c20ca2e6fa0e12b25c2aef1a8
diff --git a/dev-python/async-timeout/async-timeout-5.0.1.ebuild b/dev-python/async-timeout/async-timeout-5.0.1.ebuild
new file mode 100644
index 000000000000..c260a45b6106
--- /dev/null
+++ b/dev-python/async-timeout/async-timeout-5.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Timeout context manager for asyncio programs"
+HOMEPAGE="
+ https://github.com/aio-libs/async-timeout/
+ https://pypi.org/project/async-timeout/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p asyncio
+}