summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/autobahn')
-rw-r--r--dev-python/autobahn/autobahn-22.3.2-r1.ebuild (renamed from dev-python/autobahn/autobahn-22.3.2.ebuild)5
-rw-r--r--dev-python/autobahn/autobahn-22.4.2.ebuild5
-rw-r--r--dev-python/autobahn/autobahn-22.5.1-r1.ebuild (renamed from dev-python/autobahn/autobahn-22.5.1.ebuild)5
3 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/autobahn/autobahn-22.3.2.ebuild b/dev-python/autobahn/autobahn-22.3.2-r1.ebuild
index 6280c160e0bd..a372e795e614 100644
--- a/dev-python/autobahn/autobahn-22.3.2.ebuild
+++ b/dev-python/autobahn/autobahn-22.3.2-r1.ebuild
@@ -82,15 +82,16 @@ python_prepare_all() {
}
python_test() {
+ rm -rf autobahn || die
+
einfo "Testing all, cryptosign using twisted"
local -x USE_TWISTED=true
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
"${EPYTHON}" -m twisted.trial autobahn || die "Tests failed with ${EPYTHON}"
unset USE_TWISTED
einfo "RE-testing cryptosign and component_aio using asyncio"
local -x USE_ASYNCIO=true
- epytest autobahn/wamp/test/test_wamp_{cryptosign,component_aio}.py
+ epytest --pyargs autobahn.wamp.test.test_wamp_{cryptosign,component_aio}
unset USE_ASYNCIO
rm -f twisted/plugins/dropin.cache || die
diff --git a/dev-python/autobahn/autobahn-22.4.2.ebuild b/dev-python/autobahn/autobahn-22.4.2.ebuild
index 7bb27671fd5c..b7c800f34a87 100644
--- a/dev-python/autobahn/autobahn-22.4.2.ebuild
+++ b/dev-python/autobahn/autobahn-22.4.2.ebuild
@@ -83,15 +83,16 @@ python_prepare_all() {
}
python_test() {
+ rm -rf autobahn || die
+
einfo "Testing all, cryptosign using twisted"
local -x USE_TWISTED=true
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
"${EPYTHON}" -m twisted.trial autobahn || die "Tests failed with ${EPYTHON}"
unset USE_TWISTED
einfo "RE-testing cryptosign and component_aio using asyncio"
local -x USE_ASYNCIO=true
- epytest autobahn/wamp/test/test_wamp_{cryptosign,component_aio}.py
+ epytest --pyargs autobahn.wamp.test.test_wamp_{cryptosign,component_aio}
unset USE_ASYNCIO
rm -f twisted/plugins/dropin.cache || die
diff --git a/dev-python/autobahn/autobahn-22.5.1.ebuild b/dev-python/autobahn/autobahn-22.5.1-r1.ebuild
index f53a820194fa..b0aa9b524e50 100644
--- a/dev-python/autobahn/autobahn-22.5.1.ebuild
+++ b/dev-python/autobahn/autobahn-22.5.1-r1.ebuild
@@ -83,15 +83,16 @@ python_prepare_all() {
}
python_test() {
+ rm -rf autobahn || die
+
einfo "Testing all, cryptosign using twisted"
local -x USE_TWISTED=true
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
"${EPYTHON}" -m twisted.trial autobahn || die "Tests failed with ${EPYTHON}"
unset USE_TWISTED
einfo "RE-testing cryptosign and component_aio using asyncio"
local -x USE_ASYNCIO=true
- epytest autobahn/wamp/test/test_wamp_{cryptosign,component_aio}.py
+ epytest --pyargs autobahn.wamp.test.test_wamp_{cryptosign,component_aio}
unset USE_ASYNCIO
rm -f twisted/plugins/dropin.cache || die