summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/build-0.7.0-r1.ebuild3
-rw-r--r--dev-python/build/build-0.8.0.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/build/build-0.7.0-r1.ebuild b/dev-python/build/build-0.7.0-r1.ebuild
index 049661a8726c..6dbd928558f2 100644
--- a/dev-python/build/build-0.7.0-r1.ebuild
+++ b/dev-python/build/build-0.7.0-r1.ebuild
@@ -54,6 +54,9 @@ python_test() {
tests/test_main.py::test_build_package_via_sdist
'tests/test_util.py::test_wheel_metadata[True]'
tests/test_util.py::test_with_get_requires
+ # we don't really have to test that fallback
+ # (requires dev-python/toml that we'd like to lastrite eventually)
+ tests/test_projectbuilder.py::test_toml_instead_of_tomli
)
[[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
# fixed in git but the patch is large-ish
diff --git a/dev-python/build/build-0.8.0.ebuild b/dev-python/build/build-0.8.0.ebuild
index ca263e625e48..df040676ce48 100644
--- a/dev-python/build/build-0.8.0.ebuild
+++ b/dev-python/build/build-0.8.0.ebuild
@@ -58,6 +58,9 @@ python_test() {
tests/test_self_packaging.py::test_build_wheel
'tests/test_util.py::test_wheel_metadata[True]'
tests/test_util.py::test_with_get_requires
+ # we don't really have to test that fallback
+ # (requires dev-python/toml that we'd like to lastrite eventually)
+ tests/test_projectbuilder.py::test_toml_instead_of_tomli
)
epytest -p no:flaky -n "$(makeopts_jobs)" \