summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/catkin_pkg/catkin_pkg-9999.ebuild')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
index 46f2913d41f1..f4dc76b3fa34 100644
--- a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
SCM=""
@@ -32,13 +32,16 @@ RDEPEND="
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
+BDEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
)
"
+DEPEND="${RDEPEND} ${BDEPEND}
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
RDEPEND="${RDEPEND}
!<dev-util/catkin-0.7.14"
PATCHES=(