summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/globre')
-rw-r--r--dev-python/globre/Manifest1
-rw-r--r--dev-python/globre/globre-0.1.5.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/globre/Manifest b/dev-python/globre/Manifest
index efe358f3482b..6913e886b45f 100644
--- a/dev-python/globre/Manifest
+++ b/dev-python/globre/Manifest
@@ -1 +1,2 @@
DIST globre-0.1.4.tar.gz 19274 BLAKE2B 6b05f531e9a3819f9916d16679a39c2a281056446afc8f395ba16dcccd25878355c749820c8b1fcfdd1e855ec7a8d0f10cc5a23e3a4e77c877e0e7180e9c24dd SHA512 288b2a6e9e1b7e646f7b06db73b255f9710007c0305466a8d4e26245ab73efb14e5b543291937edb3f0d1dd9205391a08a073d106f4ed687e2a21d181a83840b
+DIST globre-0.1.5.tar.gz 20388 BLAKE2B cc3dce578d4c30d0309a60a054dfea11b53d5039adcc3251fedccc1ee8a8ceb70e844799e8a7fffb398d0f8022a51ff2460a74102d1c39f1e49d5fa2eb8fe07b SHA512 8b102150acd17a77c8c3ce1f01e36f0c9258a051b44348b6d9494ea9d2f8247bb534de250c5d506641d889042107f3b93c05a313ed46ae54f6fb47ae997ffdfa
diff --git a/dev-python/globre/globre-0.1.5.ebuild b/dev-python/globre/globre-0.1.5.ebuild
new file mode 100644
index 000000000000..310157cb58a4
--- /dev/null
+++ b/dev-python/globre/globre-0.1.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="A glob matching library, providing an interface similar to the 're' module"
+HOMEPAGE="https://pypi.org/project/globre/ https://github.com/metagriffin/globre"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests --verbose || die
+}