summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nodeenv')
-rw-r--r--dev-python/nodeenv/nodeenv-1.1.3-r1.ebuild20
-rw-r--r--dev-python/nodeenv/nodeenv-1.1.3.ebuild2
2 files changed, 21 insertions, 1 deletions
diff --git a/dev-python/nodeenv/nodeenv-1.1.3-r1.ebuild b/dev-python/nodeenv/nodeenv-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..2b42bf6059b3
--- /dev/null
+++ b/dev-python/nodeenv/nodeenv-1.1.3-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Node.js virtual environment builder"
+HOMEPAGE="https://github.com/ekalinin/nodeenv"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/nodeenv/nodeenv-1.1.3.ebuild b/dev-python/nodeenv/nodeenv-1.1.3.ebuild
index 2b8ede3a5370..2b42bf6059b3 100644
--- a/dev-python/nodeenv/nodeenv-1.1.3.ebuild
+++ b/dev-python/nodeenv/nodeenv-1.1.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )