summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rfc3987/rfc3987-1.3.8.ebuild')
-rw-r--r--dev-python/rfc3987/rfc3987-1.3.8.ebuild27
1 files changed, 0 insertions, 27 deletions
diff --git a/dev-python/rfc3987/rfc3987-1.3.8.ebuild b/dev-python/rfc3987/rfc3987-1.3.8.ebuild
deleted file mode 100644
index 8793d02c51b8..000000000000
--- a/dev-python/rfc3987/rfc3987-1.3.8.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)"
-HOMEPAGE="https://github.com/dgerber/rfc3987 https://pypi.org/project/rfc3987/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="$(python_gen_cond_dep \
- 'dev-python/regex[${PYTHON_USEDEP}]' python2_7 'python3*' pypy)"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-python_test() {
- ${EPYTHON} -m doctest -v "${S}/${PN}.py" || die
-}