summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/python_qt_binding/Manifest1
-rw-r--r--dev-ros/python_qt_binding/metadata.xml5
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.2.17.ebuild22
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-9999.ebuild22
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-ros/python_qt_binding/Manifest b/dev-ros/python_qt_binding/Manifest
new file mode 100644
index 000000000000..d46a9fc7d47d
--- /dev/null
+++ b/dev-ros/python_qt_binding/Manifest
@@ -0,0 +1 @@
+DIST python_qt_binding-0.2.17.tar.gz 12133 SHA256 7f0b5147c7b3908a09c7e771160a27d77b9047c095aa33f110345bf483b775e6 SHA512 332d63962f40d41e236a7f85e7859f1ed78dda4f02ae388e2026b53622e2551b2a702624aabf98e3fbe5d55d24f92b9c0a127386407e20ff60a5ebfbd63ffda0 WHIRLPOOL 05ecfbfaf37c94a333a517c655347f61eae17d5fa6af503e89c5f65ca624e143f7f9c097fa3f3cdda1d90b678805c1ea1228880f7074fb122fc3ebc166de2444
diff --git a/dev-ros/python_qt_binding/metadata.xml b/dev-ros/python_qt_binding/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/python_qt_binding/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.2.17.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.2.17.ebuild
new file mode 100644
index 000000000000..bf7d83c0f91a
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.2.17.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD LGPL-2.1 GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/pyside[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild b/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild
new file mode 100644
index 000000000000..bf7d83c0f91a
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD LGPL-2.1 GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/pyside[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"