summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/guile-gcrypt/guile-gcrypt-0.3.0.ebuild')
-rw-r--r--dev-scheme/guile-gcrypt/guile-gcrypt-0.3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-scheme/guile-gcrypt/guile-gcrypt-0.3.0.ebuild b/dev-scheme/guile-gcrypt/guile-gcrypt-0.3.0.ebuild
new file mode 100644
index 000000000000..3eb4f555d7c2
--- /dev/null
+++ b/dev-scheme/guile-gcrypt/guile-gcrypt-0.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Guile bindings of libgcrypt"
+HOMEPAGE="https://notabug.org/cwebber/guile-gcrypt"
+SRC_URI="https://notabug.org/cwebber/guile-gcrypt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-scheme/guile-2.0.11:=
+ dev-libs/libgcrypt:0=
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+# guile generates ELF files without use of C or machine code
+# It's a portage's false positive. bug #677600
+QA_FLAGS_IGNORED='.*[.]go'
+
+src_prepare() {
+ default
+
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+
+ # upstream tag on top of source tree. has no autogenerated files
+ eautoreconf
+}