summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/dmake')
-rw-r--r--dev-util/dmake/Manifest1
-rw-r--r--dev-util/dmake/dmake-4.13.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/dmake/Manifest b/dev-util/dmake/Manifest
index 147814062322..0598e25b45cc 100644
--- a/dev-util/dmake/Manifest
+++ b/dev-util/dmake/Manifest
@@ -1 +1,2 @@
DIST dmake-4.12.2.tar.bz2 461738 BLAKE2B 2a80f5a566f9981d61472717f1df8dcb9634975356c2ca0d4d7053ea32e74f57e5daccd11c41b81bddc7994e57e2b001fc9610800f6d949146a23b1b065b9b16 SHA512 f09453205bd425882d933a7b2cf879d69d795765bb7586e1e35ca5c9e39444cb70cfe56ed9b350f12fae8d484670b4ae418bb5d2da7c0c2ff229d9165caff45b
+DIST dmake-4.13.1.tar.gz 677296 BLAKE2B e56966569a00f5d13396ff59536194831757bd8e19a3cb66dbf28c0f7189a2791938173b94ce56c96bc5e2cbec34f48b0cba4b8ed7034b73095a0a6c4a9b477f SHA512 fc1b6cddcba174d34e709dd39f98f363ab0dff85f55c672cb231ab18c6dd045c7a3ae7483fa256effef4f5b876e71e860d0354426a30f55c30d4b04127cb3954
diff --git a/dev-util/dmake/dmake-4.13.1.ebuild b/dev-util/dmake/dmake-4.13.1.ebuild
new file mode 100644
index 000000000000..347a49b2a0e3
--- /dev/null
+++ b/dev-util/dmake/dmake-4.13.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Improved make"
+HOMEPAGE="https://jimjag.github.io/dmake/"
+SRC_URI="https://github.com/jimjag/${PN}/archive/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+BDEPEND="
+ app-arch/unzip
+ sys-apps/groff"
+
+src_prepare() {
+ default
+
+ # make tests executable, bug #404989
+ chmod +x tests/targets-{1..12} || die
+}
+
+src_install() {
+ default
+ newman man/dmake.tf dmake.1
+}