summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/xzip/files/xzip-1.8.2-clang16.patch9
-rw-r--r--games-engines/xzip/xzip-1.8.2-r4.ebuild (renamed from games-engines/xzip/xzip-1.8.2-r3.ebuild)4
2 files changed, 13 insertions, 0 deletions
diff --git a/games-engines/xzip/files/xzip-1.8.2-clang16.patch b/games-engines/xzip/files/xzip-1.8.2-clang16.patch
new file mode 100644
index 000000000000..ce702ba3e86e
--- /dev/null
+++ b/games-engines/xzip/files/xzip-1.8.2-clang16.patch
@@ -0,0 +1,9 @@
+Ideally belongs in xio.h, but using requires including more headers.
+https://bugs.gentoo.org/874906
+--- a/osdepend.c
++++ b/osdepend.c
+@@ -13,2 +13,4 @@
+
++void xio_bell();
++
+ /* File names will be O/S dependent */
diff --git a/games-engines/xzip/xzip-1.8.2-r3.ebuild b/games-engines/xzip/xzip-1.8.2-r4.ebuild
index 50bfddd967c0..04394c46e036 100644
--- a/games-engines/xzip/xzip-1.8.2-r3.ebuild
+++ b/games-engines/xzip/xzip-1.8.2-r4.ebuild
@@ -19,6 +19,10 @@ RDEPEND=${DEPEND}
S="${WORKDIR}/xzip"
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
src_compile() {
tc-export CC
emake \