summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/bsod/files/bsod-0.1-Makefile.patch')
-rw-r--r--games-misc/bsod/files/bsod-0.1-Makefile.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/games-misc/bsod/files/bsod-0.1-Makefile.patch b/games-misc/bsod/files/bsod-0.1-Makefile.patch
new file mode 100644
index 000000000000..b7699c80403b
--- /dev/null
+++ b/games-misc/bsod/files/bsod-0.1-Makefile.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,15 +1,15 @@
+ VERSION=0.1
+
+ DEBUG=-g -pedantic #-pg #-fprofile-arcs
+-LDFLAGS=-lncurses $(DEBUG)
+-CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
++LDLIBS=$(shell ${PKG_CONFIG} --libs ncurses)
++CFLAGS+=-Wall -DVERSION=\"$(VERSION)\"
+
+ OBJS=bsod.o
+
+ all: bsod
+
+ bsod: $(OBJS)
+- $(CC) -Wall $(OBJS) $(LDFLAGS) -o bsod
++ $(CC) $(LDFLAGS) $(CFLAGS) $(OBJS) $(LDLIBS) -o bsod
+
+ install: bsod
+ cp bsod $(DESTDIR)/usr/local/bin