summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/augustus/augustus-3.1.0.ebuild1
-rw-r--r--games-strategy/augustus/files/augustus-3.1.0-musl-fix-execinfo.patch12
2 files changed, 13 insertions, 0 deletions
diff --git a/games-strategy/augustus/augustus-3.1.0.ebuild b/games-strategy/augustus/augustus-3.1.0.ebuild
index 1adb27ab8703..254e4efc5a77 100644
--- a/games-strategy/augustus/augustus-3.1.0.ebuild
+++ b/games-strategy/augustus/augustus-3.1.0.ebuild
@@ -26,6 +26,7 @@ RDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-3.0.1-desktop_rename.patch"
+ "${FILESDIR}/${PN}-3.1.0-musl-fix-execinfo.patch"
)
src_prepare() {
diff --git a/games-strategy/augustus/files/augustus-3.1.0-musl-fix-execinfo.patch b/games-strategy/augustus/files/augustus-3.1.0-musl-fix-execinfo.patch
new file mode 100644
index 000000000000..97b96cf61e59
--- /dev/null
+++ b/games-strategy/augustus/files/augustus-3.1.0-musl-fix-execinfo.patch
@@ -0,0 +1,12 @@
+# Closes: https://bugs.gentoo.org/829345
+--- a/src/platform/crash_handler.c
++++ b/src/platform/crash_handler.c
+@@ -7,7 +7,7 @@
+
+ #if defined(__GNUC__) && !defined(__MINGW32__) && !defined(__OpenBSD__) && \
+ !defined(__vita__) && !defined(__SWITCH__) && !defined(__ANDROID__) && \
+- !defined(__HAIKU__) && !defined(__EMSCRIPTEN__)
++ !defined(__HAIKU__) && !defined(__EMSCRIPTEN__) && defined(__GLIBC__)
+
+ #include <execinfo.h>
+ #include <signal.h>