summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'llvm-runtimes/offload/offload-20.0.0_pre20241207.ebuild')
-rw-r--r--llvm-runtimes/offload/offload-20.0.0_pre20241207.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/llvm-runtimes/offload/offload-20.0.0_pre20241207.ebuild b/llvm-runtimes/offload/offload-20.0.0_pre20241207.ebuild
index a92e9e17cebe..d68901e769ef 100644
--- a/llvm-runtimes/offload/offload-20.0.0_pre20241207.ebuild
+++ b/llvm-runtimes/offload/offload-20.0.0_pre20241207.ebuild
@@ -26,23 +26,23 @@ DEPEND="
# tests:
# - dev-python/lit provides the test runner
# - sys-devel/llvm provide test utils (e.g. FileCheck)
-# - sys-devel/clang provides the compiler to run tests
+# - llvm-core/clang provides the compiler to run tests
BDEPEND="
dev-lang/perl
virtual/pkgconfig
- llvm_targets_AMDGPU? ( sys-devel/clang )
- llvm_targets_NVPTX? ( sys-devel/clang )
+ llvm_targets_AMDGPU? ( llvm-core/clang )
+ llvm_targets_NVPTX? ( llvm-core/clang )
test? (
${PYTHON_DEPS}
$(python_gen_any_dep '
dev-python/lit[${PYTHON_USEDEP}]
')
- sys-devel/clang
+ llvm-core/clang
)
"
# TODO: can it be fixed to compile with gcc?
BDEPEND+="
- sys-devel/clang
+ llvm-core/clang
"
LLVM_COMPONENTS=( offload cmake runtimes/cmake libc/shared )