summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild')
-rw-r--r--media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild b/media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild
index cee491df0ef9..6974e43cf260 100644
--- a/media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild
+++ b/media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit eutils toolchain-funcs
-
-IUSE=""
+inherit toolchain-funcs
DESCRIPTION="sync up 2 audio ch. and/or combine 2 mono audio ch. into one stereo wave ch"
HOMEPAGE="http://panteltje.com/panteltje/dvd/"
@@ -14,19 +12,24 @@ SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DOCS=( CHANGES README combine_wave.man )
+
+PATCHES=( "${FILESDIR}/${P}-overflow.patch" )
src_prepare() {
+ default
# fix makefile
sed -i -e "s:gcc:\$(CC):g" -e "s:= -O2:+=:g" \
- -e "s:\( -o \): \$(LDFLAGS)\1:g" Makefile
- epatch "${FILESDIR}"/${P}-overflow.patch
+ -e "s:\( -o \): \$(LDFLAGS)\1:g" Makefile || die "sed Makefile failed"
}
-src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed"
+src_configure() {
+ tc-export CC
}
src_install() {
- dobin combine_wave || die
- dodoc CHANGES README combine_wave.man
+ dobin combine_wave
+ einstalldocs
}