summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pwavecat/pwavecat-0.4.5.ebuild')
-rw-r--r--media-sound/pwavecat/pwavecat-0.4.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/pwavecat/pwavecat-0.4.5.ebuild b/media-sound/pwavecat/pwavecat-0.4.5.ebuild
new file mode 100644
index 000000000000..2c8ee6ef9ecc
--- /dev/null
+++ b/media-sound/pwavecat/pwavecat-0.4.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+IUSE=""
+
+DESCRIPTION="concatenates any number of audio files to stdout"
+HOMEPAGE="http://panteltje.com/panteltje/dvd/"
+SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}.diff" \
+ "${FILESDIR}"/${P}-overflow.patch
+}
+
+src_compile() {
+ append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin pwavecat || die
+ dodoc CHANGES README
+}