summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/cutecom')
-rw-r--r--net-dialup/cutecom/Manifest1
-rw-r--r--net-dialup/cutecom/cutecom-0.22.0-r1.ebuild40
-rw-r--r--net-dialup/cutecom/metadata.xml7
3 files changed, 48 insertions, 0 deletions
diff --git a/net-dialup/cutecom/Manifest b/net-dialup/cutecom/Manifest
new file mode 100644
index 000000000000..eae601004228
--- /dev/null
+++ b/net-dialup/cutecom/Manifest
@@ -0,0 +1 @@
+DIST cutecom-0.22.0.tar.gz 23208 SHA256 1b6620a6159cf3d50bb36cce544e91486817df7f1d553bf239d6db6108dd2ea5 SHA512 507b42b943f20d07429c3629ebdf358ca6551a57a2addc4c8560993b7c2d1304ef258f7d2ac8c62b13bcdfc797574b7e1dfac8b0c0086072407de7f71a2d0a26 WHIRLPOOL f74aea1478de99e9e3d2232451097b3090aff4ba685969cf4363aa2b0c76db079000a7e2991d790548c52bf79f31a3a11d193d1dc781aed2e34555cf2a68dd13
diff --git a/net-dialup/cutecom/cutecom-0.22.0-r1.ebuild b/net-dialup/cutecom/cutecom-0.22.0-r1.ebuild
new file mode 100644
index 000000000000..51c73689e1c2
--- /dev/null
+++ b/net-dialup/cutecom/cutecom-0.22.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils eutils
+
+DESCRIPTION="CuteCom is a serial terminal, like minicom, written in qt"
+HOMEPAGE="http://cutecom.sourceforge.net"
+SRC_URI="http://cutecom.sourceforge.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qt3support:4"
+RDEPEND="${DEPEND}
+ net-dialup/lrzsz"
+
+src_prepare() {
+ sed -i \
+ -e '/Path/d' \
+ -e '/TerminalOptions/d' \
+ -e '/BinaryPattern/d' \
+ -e '/Terminal/s/0/false/' \
+ ${PN}.desktop || die 'sed on desktop file failed'
+
+ cmake-utils_src_prepare
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # desktop icon does not installed by cmake without KDE3
+ domenu ${PN}.desktop
+}
diff --git a/net-dialup/cutecom/metadata.xml b/net-dialup/cutecom/metadata.xml
new file mode 100644
index 000000000000..4beb36871cbc
--- /dev/null
+++ b/net-dialup/cutecom/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+ <longdescription>CuteCom is a graphical serial terminal, like minicom. It is aimed mainly at hardware
+developers or other people who need a terminal to talk to their devices.</longdescription>
+</pkgmetadata>