summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/freeradius/freeradius-3.0.14.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-dialup/freeradius/freeradius-3.0.14.ebuild b/net-dialup/freeradius/freeradius-3.0.14.ebuild
index 4c5847cbcac3..e5c5443ca3c3 100644
--- a/net-dialup/freeradius/freeradius-3.0.14.ebuild
+++ b/net-dialup/freeradius/freeradius-3.0.14.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit autotools pam python-any-r1 systemd user
+inherit autotools pam python-single-r1 systemd user
MY_P="${PN}-server-${PV}"
@@ -47,13 +47,15 @@ RDEPEND="!net-dialup/cistronradius
oracle? ( dev-db/oracle-instantclient-basic )"
DEPEND="${RDEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
S="${WORKDIR}/${MY_P}"
pkg_setup() {
enewgroup radius
enewuser radius -1 -1 /var/log/radius radius
- python-any-r1_pkg_setup
+ python-single-r1_pkg_setup
export PYTHONBIN="${EPYTHON}"
}