summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/liboauth')
-rw-r--r--net-libs/liboauth/Manifest1
-rw-r--r--net-libs/liboauth/files/liboauth-1.0.1-doxygen-out-of-tree.patch50
-rw-r--r--net-libs/liboauth/liboauth-1.0.1.ebuild70
-rw-r--r--net-libs/liboauth/metadata.xml26
4 files changed, 147 insertions, 0 deletions
diff --git a/net-libs/liboauth/Manifest b/net-libs/liboauth/Manifest
new file mode 100644
index 000000000000..37cf335fb29d
--- /dev/null
+++ b/net-libs/liboauth/Manifest
@@ -0,0 +1 @@
+DIST liboauth-1.0.1.tar.gz 501706 SHA256 5087d32fe1db7b588246a7de64fc0c2464c95efdebb2c7fe6f482d9b00e68d8b SHA512 5d84699ece179a3b17eae8b7113eeadd7bd24df953f7070a6a0e303923b1661d82174894bf64ef6abc6dc344042013256fb2b1ab4fae12ab2778fa15446aa06c WHIRLPOOL 41b83bfc578b74c65018df7a73ba58695352a6e9e53a8a69434dc033c8bea1664417b2e3691dd2f1dd99ce2d55d48bde0fb4d29727294f59b5436720294236ed
diff --git a/net-libs/liboauth/files/liboauth-1.0.1-doxygen-out-of-tree.patch b/net-libs/liboauth/files/liboauth-1.0.1-doxygen-out-of-tree.patch
new file mode 100644
index 000000000000..3ed37ec266cc
--- /dev/null
+++ b/net-libs/liboauth/files/liboauth-1.0.1-doxygen-out-of-tree.patch
@@ -0,0 +1,50 @@
+diff -urp liboauth-1.0.1-orig/Doxyfile.in liboauth-1.0.1/Doxyfile.in
+--- liboauth-1.0.1-orig/Doxyfile.in 2012-11-01 04:34:49.000000000 +0000
++++ liboauth-1.0.1/Doxyfile.in 2013-03-14 14:25:11.000000000 +0000
+@@ -45,7 +45,7 @@ PROJECT_BRIEF =
+ # exceed 55 pixels and the maximum width should not exceed 200 pixels.
+ # Doxygen will copy the logo to the output directory.
+
+-PROJECT_LOGO = doc/libOAuth.png
++PROJECT_LOGO = @top_srcdir@/doc/libOAuth.png
+
+ # The OUTPUT_DIRECTORY tag is used to specify the (relative or absolute)
+ # base path where the generated documentation will be put.
+@@ -130,7 +130,7 @@ FULL_PATH_NAMES = YES
+ # relative paths, which will be relative from the directory where doxygen is
+ # started.
+
+-STRIP_FROM_PATH = src/
++STRIP_FROM_PATH = @top_srcdir@/src/
+
+ # The STRIP_FROM_INC_PATH tag can be used to strip a user-defined part of
+ # the path mentioned in the documentation of a class, which tells
+@@ -661,8 +661,8 @@ WARN_LOGFILE =
+ # directories like "/usr/src/myproject". Separate the files or directories
+ # with spaces.
+
+-INPUT = src/oauth.h \
+- doc/mainpage.dox
++INPUT = @top_srcdir@/src/oauth.h \
++ @top_srcdir@/doc/mainpage.dox
+
+ # This tag can be used to specify the character encoding of the source files
+ # that doxygen parses. Internally doxygen uses the UTF-8 encoding, which is
+@@ -722,7 +722,7 @@ EXCLUDE_SYMBOLS =
+ # directories that contain example code fragments that are included (see
+ # the \include command).
+
+-EXAMPLE_PATH = tests/
++EXAMPLE_PATH = @top_srcdir@/tests/
+
+ # If the value of the EXAMPLE_PATH tag contains directories, you can use the
+ # EXAMPLE_PATTERNS tag to specify one or more wildcard pattern (like *.cpp
+@@ -742,7 +742,7 @@ EXAMPLE_RECURSIVE = NO
+ # directories that contain image that are included in the documentation (see
+ # the \image command).
+
+-IMAGE_PATH = doc/
++IMAGE_PATH = @top_srcdir@/doc/
+
+ # The INPUT_FILTER tag can be used to specify a program that doxygen should
+ # invoke to filter for each input file. Doxygen will invoke the filter program
diff --git a/net-libs/liboauth/liboauth-1.0.1.ebuild b/net-libs/liboauth/liboauth-1.0.1.ebuild
new file mode 100644
index 000000000000..9b6d310ad18c
--- /dev/null
+++ b/net-libs/liboauth/liboauth-1.0.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="C library implementing the OAuth secure authentication protocol"
+HOMEPAGE="http://liboauth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 MIT )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x64-macos"
+IUSE="curl doc bindist +nss"
+
+PATCHES=( "${FILESDIR}"/${P}-doxygen-out-of-tree.patch )
+REQUIRED_USE="bindist? ( nss )"
+
+CDEPEND="
+ nss? ( dev-libs/nss
+ curl? ( || ( net-misc/curl[ssl,curl_ssl_nss] net-misc/curl[-ssl] ) )
+ )
+
+ !nss? ( dev-libs/openssl
+ curl? ( || ( net-misc/curl[ssl,curl_ssl_openssl] net-misc/curl[-ssl] ) )
+ )
+
+ net-misc/curl
+"
+
+RDEPEND="${CDEPEND}"
+
+DEPEND="${CDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ media-fonts/freefont
+ )
+ virtual/pkgconfig"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable !curl curl)
+ $(use_enable curl libcurl)
+ $(use_enable nss)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use doc ; then
+ # make sure fonts are found
+ export DOTFONTPATH="${EPREFIX}"/usr/share/fonts/freefont-ttf
+ autotools-utils_src_compile dox
+ fi
+}
+
+DOCS=( AUTHORS ChangeLog LICENSE.OpenSSL README )
+
+src_install() {
+ use doc && HTML_DOCS=("${BUILD_DIR}"/doc/html/)
+
+ autotools-utils_src_install
+}
diff --git a/net-libs/liboauth/metadata.xml b/net-libs/liboauth/metadata.xml
new file mode 100644
index 000000000000..6b3cdb607cdd
--- /dev/null
+++ b/net-libs/liboauth/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="nss">
+ Use Mozilla NSS (<pkg>dev-libs/nss</pkg>) as hash library; if
+ this is disabled, <pkg>dev-libs/openssl</pkg> is used instead.
+ </flag>
+ <flag name="bindist">
+ Alias for the nss USE flag, since there are license compliancy
+ trouble when using OpenSSL.
+ </flag>
+ <flag name="curl">
+ If enabled, <pkg>net-misc/curl</pkg> is used thorugh the libcurl
+ library; if it's not, the curl command is used instead. Some
+ features are only available when using the library, but using it
+ as library requires matching SSL implementations.
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">liboauth</remote-id>
+ </upstream>
+</pkgmetadata>