summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nghttp2')
-rw-r--r--net-libs/nghttp2/nghttp2-1.37.0.ebuild4
-rw-r--r--net-libs/nghttp2/nghttp2-1.38.0.ebuild4
-rw-r--r--net-libs/nghttp2/nghttp2-9999.ebuild6
3 files changed, 10 insertions, 4 deletions
diff --git a/net-libs/nghttp2/nghttp2-1.37.0.ebuild b/net-libs/nghttp2/nghttp2-1.37.0.ebuild
index 20f89187f0fb..f27032d7957e 100644
--- a/net-libs/nghttp2/nghttp2-1.37.0.ebuild
+++ b/net-libs/nghttp2/nghttp2-1.37.0.ebuild
@@ -64,5 +64,7 @@ multilib_src_configure() {
}
multilib_src_install_all() {
- use static-libs || find "${ED%/}"/usr -name '*.la' -delete
+ if ! use static-libs ; then
+ find "${ED}"/usr -name '*.la' -delete || die
+ fi
}
diff --git a/net-libs/nghttp2/nghttp2-1.38.0.ebuild b/net-libs/nghttp2/nghttp2-1.38.0.ebuild
index 633fb68774c7..1979bd70cc2c 100644
--- a/net-libs/nghttp2/nghttp2-1.38.0.ebuild
+++ b/net-libs/nghttp2/nghttp2-1.38.0.ebuild
@@ -83,5 +83,7 @@ multilib_src_configure() {
}
multilib_src_install_all() {
- use static-libs || find "${ED%/}"/usr -name '*.la' -delete
+ if ! use static-libs ; then
+ find "${ED}"/usr -name '*.la' -delete || die
+ fi
}
diff --git a/net-libs/nghttp2/nghttp2-9999.ebuild b/net-libs/nghttp2/nghttp2-9999.ebuild
index e5d039fc7180..0950bfb1def2 100644
--- a/net-libs/nghttp2/nghttp2-9999.ebuild
+++ b/net-libs/nghttp2/nghttp2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# TODO: Add python support.
@@ -69,5 +69,7 @@ multilib_src_configure() {
}
multilib_src_install_all() {
- use static-libs || find "${ED%/}"/usr -name '*.la' -delete
+ if ! use static-libs ; then
+ find "${ED}"/usr -name '*.la' -delete || die
+ fi
}