summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/acpype')
-rw-r--r--sci-chemistry/acpype/Manifest3
-rw-r--r--sci-chemistry/acpype/acpype-366.ebuild38
-rw-r--r--sci-chemistry/acpype/acpype-374.ebuild38
-rw-r--r--sci-chemistry/acpype/acpype-389.ebuild39
-rw-r--r--sci-chemistry/acpype/files/acpype.patch37
-rw-r--r--sci-chemistry/acpype/metadata.xml9
6 files changed, 164 insertions, 0 deletions
diff --git a/sci-chemistry/acpype/Manifest b/sci-chemistry/acpype/Manifest
new file mode 100644
index 000000000000..e1cd9723b479
--- /dev/null
+++ b/sci-chemistry/acpype/Manifest
@@ -0,0 +1,3 @@
+DIST acpype-366.tar.xz 539408 SHA256 f0c77abea0a5680ecbbecadc1a95c8f851159b7c84d079f6f527336d447e1e9d
+DIST acpype-374.tar.xz 521076 SHA256 60a15d1c29ba3254a17c0792ae859444641e7a9375bd24cdd8baccc27920fde3 SHA512 99915299b32878e2139f67503260b491e05f8a592c37c5668e5aea3414822965827a91e09578264cfb48684decbadfb60c833706b756ff277ffde8b15159391e WHIRLPOOL b4e59eec36438eb2ee6d05183a6f08200213923ff50fbff1377cd976c8e39cc24429eb727d890028af2b5b5ad90428c70a10821ae20b50f7fc494ff9163322a8
+DIST acpype-389.tar.xz 524460 SHA256 4fd4036308cd81a480beaa56ae65b43a8c5ee3bbfc64b07b4d0b6649602f529a SHA512 0fbcb83ae8306d6bcc1cfd921d70c67a15e14c443453ab8c4cfd7082c15b95599801abbe31a46313674aa4841c5cd5499b69cc080221acc2793dc808df247987 WHIRLPOOL 21c8ee51c651c7a519716c818b0febd5fd62384aeeb6a5ce0f8dcf877181edba75fdd15be0d5a158b5a22d051765fb231c7c10038b8da1bcd98bede848057e95
diff --git a/sci-chemistry/acpype/acpype-366.ebuild b/sci-chemistry/acpype/acpype-366.ebuild
new file mode 100644
index 000000000000..01a804da9cba
--- /dev/null
+++ b/sci-chemistry/acpype/acpype-366.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils python
+PYTHON_DEPEND="2:2.5"
+
+DESCRIPTION="AnteChamber PYthon Parser interfacE"
+HOMEPAGE="http://code.google.com/p/acpype/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+DEPEND="sci-chemistry/ambertools"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}.patch"
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ newbin ${PN}.py ${PN}
+ newbin CcpnToAcpype.py CcpnToAcpype
+ dodoc NOTE.txt README.txt
+ insinto /usr/share/${PN}
+ doins -r ffamber_additions test
+}
diff --git a/sci-chemistry/acpype/acpype-374.ebuild b/sci-chemistry/acpype/acpype-374.ebuild
new file mode 100644
index 000000000000..56036152102c
--- /dev/null
+++ b/sci-chemistry/acpype/acpype-374.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+
+inherit python
+
+DESCRIPTION="AnteChamber PYthon Parser interfacE"
+HOMEPAGE="http://code.google.com/p/acpype/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+DEPEND="sci-chemistry/ambertools"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ newbin ${PN}.py ${PN}
+ newbin CcpnToAcpype.py CcpnToAcpype
+ dodoc NOTE.txt README.txt
+ insinto /usr/share/${PN}
+ doins -r ffamber_additions test
+}
diff --git a/sci-chemistry/acpype/acpype-389.ebuild b/sci-chemistry/acpype/acpype-389.ebuild
new file mode 100644
index 000000000000..6ff35e1fcc47
--- /dev/null
+++ b/sci-chemistry/acpype/acpype-389.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="AnteChamber PYthon Parser interfacE"
+HOMEPAGE="http://code.google.com/p/acpype/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ sci-chemistry/ambertools"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed \
+ -e '1s:^:#!/usr/bin/python\n\n:g' \
+ -i CcpnToAcpype.py || die
+}
+
+src_install() {
+ python_parallel_foreach_impl python_newscript ${PN}.py ${PN}
+ python_parallel_foreach_impl python_newscript CcpnToAcpype.py CcpnToAcpype
+ dodoc NOTE.txt README.txt
+ insinto /usr/share/${PN}
+ doins -r ffamber_additions test
+}
diff --git a/sci-chemistry/acpype/files/acpype.patch b/sci-chemistry/acpype/files/acpype.patch
new file mode 100644
index 000000000000..9354527cc8a9
--- /dev/null
+++ b/sci-chemistry/acpype/files/acpype.patch
@@ -0,0 +1,37 @@
+Index: acpype.py
+===================================================================
+--- acpype.py (revision 366)
++++ acpype.py (working copy)
+@@ -3020,32 +3020,6 @@
+ acMol2FileName = '%s_%s_%s.mol2' % (base, chargeType, atomType)
+ self.acMol2FileName = acMol2FileName
+ self.charmmBase = '%s_CHARMM' % base
+- # check for which version of antechamber
+- if 'amber10' in self.acExe:
+- if qprog == 'sqm':
+- self.printWarn("SQM is not implemented in AmberTools 1.2")
+- self.printWarn("Setting mopac for antechamber")
+- qprog = 'mopac'
+- elif qprog == 'divcon':
+- if not os.path.exists(os.path.join(os.path.dirname(self.acExe), qprog)):
+- self.printWarn("DIVCON is not installed")
+- self.printWarn("Setting mopac for antechamber")
+- qprog = 'mopac'
+- elif 'amber11' in self.acExe:
+- if qprog == 'divcon':
+- self.printWarn("DIVCON is not implemented in AmberTools 1.3 anymore")
+- self.printWarn("Setting sqm for antechamber")
+- qprog = 'sqm'
+- elif qprog == 'mopac':
+- if not os.path.exists(os.path.join(os.path.dirname(self.acExe), qprog)):
+- self.printWarn("MOPAC is not installed")
+- self.printWarn("Setting sqm for antechamber")
+- return None
+- qprog = 'sqm'
+- else:
+- self.printWarn("Old version of antechamber. Strongly consider upgrading to AmberTools")
+- self.printWarn("Setting mopac for antechamber")
+- qprog = 'mopac'
+ self.qFlag = qDict[qprog]
+ self.outTopols = [outTopol]
+ if outTopol == 'all':
diff --git a/sci-chemistry/acpype/metadata.xml b/sci-chemistry/acpype/metadata.xml
new file mode 100644
index 000000000000..13ef0bf5a17c
--- /dev/null
+++ b/sci-chemistry/acpype/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+</pkgmetadata>