summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/opencpn-plugin-weatherfax')
-rw-r--r--sci-geosciences/opencpn-plugin-weatherfax/Manifest1
-rw-r--r--sci-geosciences/opencpn-plugin-weatherfax/metadata.xml12
-rw-r--r--sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-1.3.ebuild29
3 files changed, 42 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-weatherfax/Manifest b/sci-geosciences/opencpn-plugin-weatherfax/Manifest
new file mode 100644
index 000000000000..d79398a632ca
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-weatherfax/Manifest
@@ -0,0 +1 @@
+DIST opencpn-plugin-weatherfax-1.3.tar.gz 505937 SHA256 2b312259bc632416a53edd7d607fd26c8debd0d499e984b4da92bd8521c9de9f SHA512 54fe8f25a21d373ab00bcd5d77950532bb06c5324cdd1082e4109cad8a33b714ed0d7cd8ebe7e9540e5e10039b2a0fe23b4b88df0244f1e84b852111807ad6e4 WHIRLPOOL 654f1dd8cf93973a91d1200594896e91e2b22074023576c6b2e42cd21c271dec4ec5f9c2d1285c6b8f0d58331be6dc03c35c823d0a06123cbe2e20a03d2395d2
diff --git a/sci-geosciences/opencpn-plugin-weatherfax/metadata.xml b/sci-geosciences/opencpn-plugin-weatherfax/metadata.xml
new file mode 100644
index 000000000000..d84967ebbf7c
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-weatherfax/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-geosciences</herd>
+ <maintainer>
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">seandepagnier/weatherfax_pi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-1.3.ebuild b/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-1.3.ebuild
new file mode 100644
index 000000000000..7dc771b54bcd
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+inherit cmake-utils wxwidgets
+
+MY_PN="weatherfax_pi"
+
+DESCRIPTION="Weatherfax Plugin for OpenCPN"
+HOMEPAGE="http://opencpn.org/ocpn/downloadplugins"
+SRC_URI="
+ https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sci-geosciences/opencpn-4.0.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"