summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/easycrypt/easycrypt-1.0_pre20211210.ebuild')
-rw-r--r--sci-mathematics/easycrypt/easycrypt-1.0_pre20211210.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-mathematics/easycrypt/easycrypt-1.0_pre20211210.ebuild b/sci-mathematics/easycrypt/easycrypt-1.0_pre20211210.ebuild
new file mode 100644
index 000000000000..3752d3493756
--- /dev/null
+++ b/sci-mathematics/easycrypt/easycrypt-1.0_pre20211210.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="49aec58ea63a64adcf5fbabcc14c6739f337b206"
+
+inherit dune
+
+DESCRIPTION="Computer-Aided Cryptographic Proofs"
+HOMEPAGE="https://github.com/EasyCrypt/easycrypt"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
+else
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+fi
+
+LICENSE="CeCILL-B CeCILL-C"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt]
+ >=sci-mathematics/why3-1.4:=
+ dev-ml/batteries:=
+ dev-ml/camlzip:=
+ dev-ml/dune-build-info:=
+ dev-ml/dune-site:=
+ dev-ml/ocaml-inifiles:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/yojson:=
+ dev-ml/zarith:=
+"
+DEPEND="${RDEPEND}"