summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/pspp/files')
-rw-r--r--sci-mathematics/pspp/files/50pspp-gentoo.el6
-rw-r--r--sci-mathematics/pspp/files/pspp-0.8.0-gettext.patch10
-rw-r--r--sci-mathematics/pspp/files/pspp-0.8.1-oos.patch28
-rw-r--r--sci-mathematics/pspp/files/pspp-0.8.1-underlinking.patch29
4 files changed, 73 insertions, 0 deletions
diff --git a/sci-mathematics/pspp/files/50pspp-gentoo.el b/sci-mathematics/pspp/files/50pspp-gentoo.el
new file mode 100644
index 000000000000..adac2e8ed1da
--- /dev/null
+++ b/sci-mathematics/pspp/files/50pspp-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; pspp site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'pspp-mode "pspp-mode" nil t)
+(add-to-list 'auto-mode-alist '("\\.sps\\'" . pspp-mode))
diff --git a/sci-mathematics/pspp/files/pspp-0.8.0-gettext.patch b/sci-mathematics/pspp/files/pspp-0.8.0-gettext.patch
new file mode 100644
index 000000000000..73fb8dc8790a
--- /dev/null
+++ b/sci-mathematics/pspp/files/pspp-0.8.0-gettext.patch
@@ -0,0 +1,10 @@
+--- configure.ac.orig 2013-08-06 10:18:37.329909242 -0700
++++ configure.ac 2013-08-06 10:18:51.011975942 -0700
+@@ -30,6 +30,7 @@
+
+ dnl Disable automatic po/ support, because PSPP provides its own po/ support.
+ AC_PROVIDE([AM_PO_SUBDIRS])
++AM_GNU_GETTEXT_VERSION([0.17])
+ AM_GNU_GETTEXT([external], [need-ngettext])
+ LIBS="$LIBINTL $LIBS"
+
diff --git a/sci-mathematics/pspp/files/pspp-0.8.1-oos.patch b/sci-mathematics/pspp/files/pspp-0.8.1-oos.patch
new file mode 100644
index 000000000000..51612b993abd
--- /dev/null
+++ b/sci-mathematics/pspp/files/pspp-0.8.1-oos.patch
@@ -0,0 +1,28 @@
+ src/ui/gui/automake.mk | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/ui/gui/automake.mk b/src/ui/gui/automake.mk
+index 47a3215..24f5b0b 100644
+--- a/src/ui/gui/automake.mk
++++ b/src/ui/gui/automake.mk
+@@ -333,16 +333,16 @@ PHONY += yelp-check
+ AM_CPPFLAGS += -Isrc
+
+ src/ui/gui/pspp.desktop: src/ui/gui/gen-dot-desktop.sh $(POFILES)
+- POFILES="$(POFILES)" top_builddir="$(top_builddir)" $(SHELL) $< > $@
++ POFILES="$(POFILES)" top_builddir="$(top_builddir)" $(SHELL) $< > ${top_srcdir}/$@
+
+ CLEANFILES+=src/ui/gui/pspp.desktop
+
+ src/ui/gui/psppire-marshal.c: src/ui/gui/marshaller-list
+- echo '#include <config.h>' > $@
+- $(GLIB_GENMARSHAL) --body --prefix=psppire_marshal $? >> $@
++ echo '#include <config.h>' > ${top_srcdir}/$@
++ $(GLIB_GENMARSHAL) --body --prefix=psppire_marshal $? >> ${top_srcdir}/$@
+
+ src/ui/gui/psppire-marshal.h: src/ui/gui/marshaller-list
+- $(GLIB_GENMARSHAL) --header --prefix=psppire_marshal $? > $@
++ $(GLIB_GENMARSHAL) --header --prefix=psppire_marshal $? > ${top_srcdir}/$@
+
+ desktopdir = $(datadir)/applications
+ desktop_DATA = src/ui/gui/pspp.desktop
diff --git a/sci-mathematics/pspp/files/pspp-0.8.1-underlinking.patch b/sci-mathematics/pspp/files/pspp-0.8.1-underlinking.patch
new file mode 100644
index 000000000000..2c533ee49658
--- /dev/null
+++ b/sci-mathematics/pspp/files/pspp-0.8.1-underlinking.patch
@@ -0,0 +1,29 @@
+ src/automake.mk | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/src/automake.mk b/src/automake.mk
+index 73ff813..8524000 100644
+--- a/src/automake.mk
++++ b/src/automake.mk
+@@ -20,7 +20,7 @@ src_libpspp_core_la_LIBADD = \
+ src/data/libdata.la \
+ src/libpspp/liblibpspp.la \
+ $(LIBXML2_LIBS) $(PG_LIBS) \
+- gl/libgl.la
++ gl/libgl.la $(CAIRO_LIBS)
+
+ src_libpspp_la_SOURCES =
+
+@@ -28,10 +28,11 @@ src_libpspp_la_CFLAGS = $(GSL_CFLAGS)
+ src_libpspp_la_LDFLAGS = -release $(VERSION)
+
+ src_libpspp_la_LIBADD = \
++ src/libpspp-core.la \
+ src/language/liblanguage.la \
+ src/math/libpspp-math.la \
+ src/output/liboutput.la \
+- $(GSL_LIBS)
++ $(GSL_LIBS) $(CAIRO_LIBS) $(LIBXML2_LIBS)
+
+ include $(top_srcdir)/src/math/automake.mk
+ include $(top_srcdir)/src/output/automake.mk