summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/paw')
-rw-r--r--sci-physics/paw/Manifest3
-rw-r--r--sci-physics/paw/files/paw-2.14.04-glibc-2.10.patch11
-rw-r--r--sci-physics/paw/metadata.xml15
-rw-r--r--sci-physics/paw/paw-2.14.04-r4.ebuild72
-rw-r--r--sci-physics/paw/paw-2.14.04-r5.ebuild72
5 files changed, 173 insertions, 0 deletions
diff --git a/sci-physics/paw/Manifest b/sci-physics/paw/Manifest
new file mode 100644
index 000000000000..964e89136fe0
--- /dev/null
+++ b/sci-physics/paw/Manifest
@@ -0,0 +1,3 @@
+DIST paw_2.14.04.dfsg.2-8.debian.tar.gz 75788 SHA256 1fa912310f5c2eb4cd856fca53808d6142451fc6be4ffa3be14f54195f8e2203 SHA512 63800b6071c0614d3d68eceffc23117703a9e48f6a9da3fd160b2eb27b326ffe7dc38718245d40e713b2c047967233e1aa56e7381754bbc95804b4c208d1d270 WHIRLPOOL 38899fa56f370cc4cbae0d593006a09cee451ecfb97b8d236b18bc4a36bfde7d5c4891a9309bd9e8bad9da8d8ba8691fc77b37f7e48545b989f6b9983e61ab38
+DIST paw_2.14.04.dfsg.2-9.debian.tar.gz 79495 SHA256 ff00ccfbc79ea3e727678ff0098d08a87851bc6a18a22b15ddd7e9a7634cef48 SHA512 e0ffd28aef621fbe7ff372bf1add2c3614897c755ada061d80835e43f0e7ebe342c44f5c989110ce53d8896d9738798277689bcb9fcba87c4eeae89e4d340b81 WHIRLPOOL befbf2ef10f1cf28733e06f5d08f36cd1eda8af99640aaf680daec9954ed1ca52a29599855c77e09a949306590a926eba13a5236dc3810debe528c0e720d5bf3
+DIST paw_2.14.04.dfsg.2.orig.tar.gz 3334317 SHA256 68925384706a4a61c477a48ed0fad539d214a4b04fdb9db5ef4e8d453f26c44e SHA512 6e4ef312195936b42ad641a63335586f48e0383e8a7f4330d52173492584f9d03c5fa4eab7e7de594e30556a1daacbe162b4f879718c9c489cb7a89f072b962e WHIRLPOOL a1c78a8d66cc10a1014a96d0b276fc0bf0725ff08ed6055ff4be9c194d50d1416ea32bfae32ea18d1b919d03ff2746c0bda29b74c15b2296f211d58086951551
diff --git a/sci-physics/paw/files/paw-2.14.04-glibc-2.10.patch b/sci-physics/paw/files/paw-2.14.04-glibc-2.10.patch
new file mode 100644
index 000000000000..7cfa5aa03d12
--- /dev/null
+++ b/sci-physics/paw/files/paw-2.14.04-glibc-2.10.patch
@@ -0,0 +1,11 @@
+--- src/pawlib/paw/cpaw/bugrep.c.orig 2009-07-13 00:38:38.000000000 +0400
++++ src/pawlib/paw/cpaw/bugrep.c 2009-07-13 08:47:54.934308924 +0400
+@@ -20,6 +20,8 @@
+ * Paw
+ *
+ */
++#define _POSIX_SOURCE
++
+ #include "paw/pilot.h"
+ #if defined(CERNLIB_BUGREPORT)
+ /*CMZ : 2.07/19 21/11/95 18.17.13 by Unknown*/
diff --git a/sci-physics/paw/metadata.xml b/sci-physics/paw/metadata.xml
new file mode 100644
index 000000000000..9450758ff229
--- /dev/null
+++ b/sci-physics/paw/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ PAW is an interactive program providing interactive graphical
+ presentation and statistical and mathematical analysis tools. It is
+ designed to work on objects familiar to physicists such as histograms,
+ event files (Ntuples), vectors, etc.
+ The program is linked statically against the CERN libraries on 64-bit
+ architectures in order to function properly, as its design is not very
+ 64-bit clean. Even so, AMD64 is the only 64-bit platform where it
+ functions well.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-physics/paw/paw-2.14.04-r4.ebuild b/sci-physics/paw/paw-2.14.04-r4.ebuild
new file mode 100644
index 000000000000..a223aad0e5e5
--- /dev/null
+++ b/sci-physics/paw/paw-2.14.04-r4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs fortran-2
+
+DEB_PN=paw
+DEB_PV=${PV}.dfsg.2
+DEB_PR=8
+DEB_P=${DEB_PN}_${DEB_PV}
+
+DESCRIPTION="CERN's Physics Analysis Workstation data analysis program"
+HOMEPAGE="https://paw.web.cern.ch/paw/"
+SRC_URI="
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.debian.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2 BSD"
+KEYWORDS="amd64 hppa sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sci-physics/cernlib
+ x11-libs/libXaw
+ >=x11-libs/motif-2.3:0
+ x11-libs/xbae"
+DEPEND="${RDEPEND}
+ dev-lang/cfortran
+ virtual/latex-base
+ x11-misc/imake
+ x11-misc/makedepend"
+
+S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
+
+src_prepare() {
+ mv ../debian . && cp debian/add-ons/Makefile .
+ export DEB_BUILD_OPTIONS="$(tc-getFC) nostrip nocheck"
+
+ # fix some path stuff and collision for comis.h,
+ # already installed by cernlib and replace hardcoded fortran compiler
+ sed -i \
+ -e "s:/usr/local:${EROOT}/usr:g" \
+ -e '/comis.h/d' \
+ -e "s/gfortran/$(tc-getFC)/g" \
+ Makefile || die
+
+ einfo "Applying Debian patches"
+ emake -j1 patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ # since we depend on cfortran, do not use the one from cernlib
+ rm src/include/cfortran/cfortran.h || die
+ sed -i \
+ -e "s|\(ArCmdBase[[:space:]]*\)ar|\1$(tc-getAR)|g" \
+ -e "s|\(RanlibCmd[[:space:]]*\)ranlib|\1$(tc-getRANLIB)|g" \
+ src/config/Imake.tmpl \
+ || die "sed Imake.tmpl failed"
+}
+
+src_compile() {
+ VARTEXFONTS="${T}"/fonts
+ emake -j1 cernlib-indep cernlib-arch
+}
+
+src_install() {
+ default
+ cd debian
+ dodoc changelog README.* deadpool.txt copyright
+ newdoc add-ons/README README.add-ons
+}
diff --git a/sci-physics/paw/paw-2.14.04-r5.ebuild b/sci-physics/paw/paw-2.14.04-r5.ebuild
new file mode 100644
index 000000000000..8f170c1d7e36
--- /dev/null
+++ b/sci-physics/paw/paw-2.14.04-r5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs fortran-2
+
+DEB_PN=paw
+DEB_PV=${PV}.dfsg.2
+DEB_PR=9
+DEB_P=${DEB_PN}_${DEB_PV}
+
+DESCRIPTION="CERN's Physics Analysis Workstation data analysis program"
+HOMEPAGE="https://paw.web.cern.ch/paw/"
+SRC_URI="
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.debian.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2 BSD"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sci-physics/cernlib
+ x11-libs/libXaw
+ >=x11-libs/motif-2.3:0
+ x11-libs/xbae"
+DEPEND="${RDEPEND}
+ dev-lang/cfortran
+ virtual/latex-base
+ x11-misc/imake
+ x11-misc/makedepend"
+
+S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
+
+src_prepare() {
+ mv ../debian . && cp debian/add-ons/Makefile .
+ export DEB_BUILD_OPTIONS="$(tc-getFC) nostrip nocheck"
+
+ # fix some path stuff and collision for comis.h,
+ # already installed by cernlib and replace hardcoded fortran compiler
+ sed -i \
+ -e "s:/usr/local:${EROOT}/usr:g" \
+ -e '/comis.h/d' \
+ -e "s/gfortran/$(tc-getFC)/g" \
+ Makefile || die
+
+ einfo "Applying Debian patches"
+ emake -j1 patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ # since we depend on cfortran, do not use the one from cernlib
+ rm src/include/cfortran/cfortran.h || die
+ sed -i \
+ -e "s|\(ArCmdBase[[:space:]]*\)ar|\1$(tc-getAR)|g" \
+ -e "s|\(RanlibCmd[[:space:]]*\)ranlib|\1$(tc-getRANLIB)|g" \
+ src/config/Imake.tmpl \
+ || die "sed Imake.tmpl failed"
+}
+
+src_compile() {
+ VARTEXFONTS="${T}"/fonts
+ emake -j1 cernlib-indep cernlib-arch
+}
+
+src_install() {
+ default
+ cd debian
+ dodoc changelog README.* deadpool.txt copyright
+ newdoc add-ons/README README.add-ons
+}