summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/bleachbit')
-rw-r--r--sys-apps/bleachbit/Manifest3
-rw-r--r--sys-apps/bleachbit/bleachbit-1.2.ebuild65
-rw-r--r--sys-apps/bleachbit/bleachbit-1.4.ebuild65
-rw-r--r--sys-apps/bleachbit/bleachbit-1.9.1.ebuild65
-rw-r--r--sys-apps/bleachbit/metadata.xml12
5 files changed, 210 insertions, 0 deletions
diff --git a/sys-apps/bleachbit/Manifest b/sys-apps/bleachbit/Manifest
new file mode 100644
index 000000000000..1cade2bbe62a
--- /dev/null
+++ b/sys-apps/bleachbit/Manifest
@@ -0,0 +1,3 @@
+DIST bleachbit-1.2.tar.bz2 346530 SHA256 655b6e1ef7d5658c8e1a8e62b2c4ae0e4b1af484e47f1fb93a735892bbd2eea3 SHA512 a84881789c408335493b0923b51e66940295c430b2ea8838e420603ef8ee7548a0a1d605564070034bfe3a2d9159015e403db14470d6b33cf5260c3e4b43d267 WHIRLPOOL 262b7261188097d36584019a38ce8ef291572b85be318f39a6bb603546a39c733b9da761763b1234b8762bae4bde8dd0ee7cb8bac5abcebe3541f81025f5fff8
+DIST bleachbit-1.4.tar.bz2 351729 SHA256 6ccba22b865718e4b72fdba527af71b79b01cbd63108f1cfe845eababf4bd0b3 SHA512 e460f65f1f732d20723d8f64685209959c1482ecff385ccb779baad866af0d4b7004b14351ec3f8d3179c5bd94edfdfc9a2e1413c414d61d45cbe361cb41f375 WHIRLPOOL b6b735fe62dadbb5874d3577e4e7a31b8de275e89a0bd1325a3680f91e06e4b773752226c55a4b90caaa6bf01e18e8111fa2277c4ff3d34c156922ceb96e2051
+DIST bleachbit-1.9.1.tar.bz2 371882 SHA256 8d15c6d849043f44a184d85c2b79324c7441d40f348493acb9a2fc8f675b4c51 SHA512 a72f35be5f0de07fe5dc6f5fd5cea4c235249f2a7714e820e91bfabc41585e2c31bb316779760a3755579ade0cfe310101bf0c70f919b9cf1f37872ac0dfb23a WHIRLPOOL 98cfd1d4597d77b337d87ab0b52f38e7608b4acdca1e44b1c6c432c0649b660b54350271d0ac9449761d6bb0609a32093f0ada941140bbff457f8dbc25d51bf2
diff --git a/sys-apps/bleachbit/bleachbit-1.2.ebuild b/sys-apps/bleachbit/bleachbit-1.2.ebuild
new file mode 100644
index 000000000000..bad30be4768b
--- /dev/null
+++ b/sys-apps/bleachbit/bleachbit-1.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="ar ast be bg bn bs ca cs da de el en_AU en_GB eo es et eu fa fi fo fr gl he hi hr hu hy ia id it ja ko ku ky lt ms
+my nb nds nl pl pt_BR pt ro ru se si sk sl sr sv ta te th tr ug uk uz vi zh_CN zh_TW"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 eutils l10n
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="http://bleachbit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+gtk nls"
+
+RDEPEND="gtk? ( dev-python/pygtk:2[$PYTHON_USEDEP] )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+DOCS=( README )
+
+python_prepare_all() {
+ rem_locale() {
+ rm "po/${1}.po" || die "removing of ${1}.po failed"
+ }
+
+ l10n_find_plocales_changes po "" ".po"
+ l10n_for_each_disabled_locale_do rem_locale
+
+ addpredict /root/.gnome2 #401981
+
+ # warning: key "Encoding" in group "Desktop Entry" is deprecated
+ sed -i -e '/Encoding/d' ${PN}.desktop || die
+
+ # choose correct Python implementation, bug #465254
+ sed -i -e 's/python/$(PYTHON)/g' po/Makefile || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use nls && emake -C po
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use nls && emake -C po DESTDIR="${D}" install
+
+ # http://bugs.gentoo.org/388999
+ insinto /usr/share/${PN}/cleaners
+ doins cleaners/*.xml
+
+ newbin ${PN}.py ${PN}
+ python_replicate_script "${D}/usr/bin/${PN}"
+
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+}
diff --git a/sys-apps/bleachbit/bleachbit-1.4.ebuild b/sys-apps/bleachbit/bleachbit-1.4.ebuild
new file mode 100644
index 000000000000..fe0b6f7f1373
--- /dev/null
+++ b/sys-apps/bleachbit/bleachbit-1.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="ar ast be bg bn bs ca cs da de el en_AU en_GB eo es et eu fa fi fo fr gl he hi hr hu hy ia id it ja ko ku ky lt ms
+my nb nds nl pl pt_BR pt ro ru se si sk sl sr sv ta te th tr ug uk uz vi zh_CN zh_TW"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 eutils l10n
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="http://bleachbit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk nls"
+
+RDEPEND="gtk? ( dev-python/pygtk:2[$PYTHON_USEDEP] )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+DOCS=( README )
+
+python_prepare_all() {
+ rem_locale() {
+ rm "po/${1}.po" || die "removing of ${1}.po failed"
+ }
+
+ l10n_find_plocales_changes po "" ".po"
+ l10n_for_each_disabled_locale_do rem_locale
+
+ addpredict /root/.gnome2 #401981
+
+ # warning: key "Encoding" in group "Desktop Entry" is deprecated
+ sed -i -e '/Encoding/d' ${PN}.desktop || die
+
+ # choose correct Python implementation, bug #465254
+ sed -i -e 's/python/$(PYTHON)/g' po/Makefile || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use nls && emake -C po
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use nls && emake -C po DESTDIR="${D}" install
+
+ # http://bugs.gentoo.org/388999
+ insinto /usr/share/${PN}/cleaners
+ doins cleaners/*.xml
+
+ newbin ${PN}.py ${PN}
+ python_replicate_script "${D}/usr/bin/${PN}"
+
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+}
diff --git a/sys-apps/bleachbit/bleachbit-1.9.1.ebuild b/sys-apps/bleachbit/bleachbit-1.9.1.ebuild
new file mode 100644
index 000000000000..d07636decf75
--- /dev/null
+++ b/sys-apps/bleachbit/bleachbit-1.9.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="ar ast be bg bn bs ca cs da de el en_AU en_GB eo es et eu fa fi fo fr gl he hi hr hu hy ia id it ja ko ku ky lt lv
+ms my nb nds nl nn pl pt_BR pt ro ru se si sk sl sr sv ta te th tr ug uk uz vi zh_CN zh_TW"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 eutils l10n
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="http://bleachbit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk nls"
+
+RDEPEND="gtk? ( dev-python/pygtk:2[$PYTHON_USEDEP] )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+DOCS=( README.md )
+
+python_prepare_all() {
+ rem_locale() {
+ rm "po/${1}.po" || die "removing of ${1}.po failed"
+ }
+
+ l10n_find_plocales_changes po "" ".po"
+ l10n_for_each_disabled_locale_do rem_locale
+
+ #addpredict /root/.gnome2 #401981
+
+ # warning: key "Encoding" in group "Desktop Entry" is deprecated
+ sed -i -e '/Encoding/d' ${PN}.desktop || die
+
+ # choose correct Python implementation, bug #465254
+ sed -i -e 's/python/$(PYTHON)/g' po/Makefile || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use nls && emake -C po
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use nls && emake -C po DESTDIR="${D}" install
+
+ # http://bugs.gentoo.org/388999
+ insinto /usr/share/${PN}/cleaners
+ doins cleaners/*.xml
+
+ newbin ${PN}.py ${PN}
+ python_replicate_script "${D}/usr/bin/${PN}"
+
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+}
diff --git a/sys-apps/bleachbit/metadata.xml b/sys-apps/bleachbit/metadata.xml
new file mode 100644
index 000000000000..21591c8dd36e
--- /dev/null
+++ b/sys-apps/bleachbit/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dastergon@gentoo.org</email>
+ <name>Pavlos Ratis</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">bleachbit</remote-id>
+ <bugs-to>http://bugs.launchpad.net/bleachbit</bugs-to>
+ </upstream>
+</pkgmetadata>