summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/hpx')
-rw-r--r--sys-cluster/hpx/hpx-1.2.1.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/sys-cluster/hpx/hpx-1.2.1.ebuild b/sys-cluster/hpx/hpx-1.2.1.ebuild
index e4605b1b99ce..a57d12d298d1 100644
--- a/sys-cluster/hpx/hpx-1.2.1.ebuild
+++ b/sys-cluster/hpx/hpx-1.2.1.ebuild
@@ -46,22 +46,22 @@ pkg_setup() {
}
src_configure() {
- CMAKE_BUILD_TYPE=Release
local mycmakeargs=(
- -DHPX_BUILD_EXAMPLES=OFF
- -DHPX_MALLOC=system
- -DLIB=$(get_libdir)
- -Dcmake_dir=cmake
- -DHPX_BUILD_DOCUMENTATION=$(usex doc)
- -DHPX_JEMALLOC=$(usex jemalloc)
+ -DHPX_WITH_EXAMPLES=OFF
+ -DHPX_WITH_DOCUMENTATION=$(usex doc)
+ -DHPX_WITH_PAPI=$(usex papi)
+ -DHPX_WITH_GOOGLE_PERFTOOLS=$(usex perftools)
-DBUILD_TESTING=$(usex test)
- -DHPX_GOOGLE_PERFTOOLS=$(usex perftools)
- -DHPX_PAPI=$(usex papi)
)
-
- use jemalloc && mycmakeargs+=( -DHPX_MALLOC=jemalloc )
- use perftools && mycmakeargs+=( -DHPX_MALLOC=tcmalloc )
- use tbb && mycmakeargs+=( -DHPX_MALLOC=tbbmalloc )
+ if use jemalloc; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=jemalloc )
+ elif use perftools; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=tcmalloc )
+ elif use tbb; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=tbbmalloc )
+ else
+ mycmakeargs+=( -DHPX_WITH_MALLOC=system )
+ fi
cmake-utils_src_configure
}
@@ -73,8 +73,8 @@ src_test() {
src_install() {
cmake-utils_src_install
- mv "${D}/usr/bin/spin" "${D}/usr/bin/hpx_spin" || die
if use examples; then
+ mv "${D}/usr/bin/spin" "${D}/usr/bin/hpx_spin" || die
insinto /usr/share/doc/${PF}
doins -r examples
fi