summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.0.9999.ebuild')
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.0.9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.0.9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.0.9999.ebuild
index 5fc5bbc62475..b9f483144cde 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-13.0.0.9999.ebuild
@@ -24,8 +24,10 @@ SANITIZER_FLAGS=(
IUSE+=" ${SANITIZER_FLAGS[@]/#/+}"
REQUIRED_USE="
|| ( ${SANITIZER_FLAGS[*]} libfuzzer profile xray )
- gwp-asan? ( scudo )
- ubsan? ( cfi )"
+ test? (
+ cfi? ( ubsan )
+ gwp-asan? ( scudo )
+ )"
RESTRICT="!test? ( test ) !clang? ( test )"
CLANG_SLOT=${SLOT%%.*}
@@ -86,10 +88,13 @@ src_prepare() {
fi
done
+ # TODO: fix these tests to be skipped upstream
if use asan && ! use profile; then
- # TODO: fix these tests to be skipped upstream
rm test/asan/TestCases/asan_and_llvm_coverage_test.cpp || die
fi
+ if use ubsan && ! use cfi; then
+ > test/cfi/CMakeLists.txt || die
+ fi
llvm.org_src_prepare
}