summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/radicale/radicale-3.1.4.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/www-apps/radicale/radicale-3.1.4.ebuild b/www-apps/radicale/radicale-3.1.4.ebuild
index 342958f23b79..de12724cd7bf 100644
--- a/www-apps/radicale/radicale-3.1.4.ebuild
+++ b/www-apps/radicale/radicale-3.1.4.ebuild
@@ -3,8 +3,7 @@
EAPI=8
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 systemd
@@ -36,6 +35,8 @@ BDEPEND="
)
"
+distutils_enable_tests --install pytest
+
S="${WORKDIR}/${MY_P}"
RDIR=/var/lib/"${PN}"
@@ -47,8 +48,6 @@ src_prepare() {
distutils-r1_src_prepare
}
-distutils_enable_tests --install pytest
-
python_test() {
epytest radicale/tests/
}