summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xsm/xsm-1.0.4.ebuild')
-rw-r--r--x11-apps/xsm/xsm-1.0.4.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/x11-apps/xsm/xsm-1.0.4.ebuild b/x11-apps/xsm/xsm-1.0.4.ebuild
index ddd4fcc32c10..a29b381dec80 100644
--- a/x11-apps/xsm/xsm-1.0.4.ebuild
+++ b/x11-apps/xsm/xsm-1.0.4.ebuild
@@ -1,32 +1,27 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit xorg-2
+inherit xorg-3
DESCRIPTION="X Session Manager"
+
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="rsh"
+
RDEPEND="x11-libs/libXaw
x11-libs/libX11
x11-libs/libXt
x11-libs/libICE
- x11-libs/libSM
- rsh? ( net-misc/netkit-rsh )"
+ x11-libs/libSM"
DEPEND="${RDEPEND}"
pkg_setup() {
# (#158056) /usr/$(get_libdir)/X11/xsm could be a symlink
- local XSMPATH="${EROOT}usr/$(get_libdir)/X11/xsm"
+ local XSMPATH="${EROOT}/usr/$(get_libdir)/X11/xsm"
if [[ -L ${XSMPATH} ]]; then
einfo "Removing symlink ${XSMPATH}"
rm -f ${XSMPATH} || die "failed to remove symlink ${XSMPATH}"
fi
- xorg-2_pkg_setup
-}
-
-src_configure() {
- XORG_CONFIGURE_OPTIONS="$(use_with rsh rsh /usr/bin/rsh)"
- xorg-2_src_configure
+ xorg-3_pkg_setup
}