From 94924e5875c223bf17e5523d5b2b0b77e783bb42 Mon Sep 17 00:00:00 2001
From: "Jason A. Donenfeld" <zx2c4@gentoo.org>
Date: Wed, 16 Nov 2016 21:50:01 +0100
Subject: net-misc/wireguard: bump

Package-Manager: portage-2.3.2
---
 net-misc/wireguard/Manifest                        |   2 +-
 net-misc/wireguard/wireguard-0.0.20161116.1.ebuild | 102 +++++++++++++++++++++
 net-misc/wireguard/wireguard-0.0.20161116.ebuild   | 102 ---------------------
 3 files changed, 103 insertions(+), 103 deletions(-)
 create mode 100644 net-misc/wireguard/wireguard-0.0.20161116.1.ebuild
 delete mode 100644 net-misc/wireguard/wireguard-0.0.20161116.ebuild

diff --git a/net-misc/wireguard/Manifest b/net-misc/wireguard/Manifest
index ff0f8dba3936..a2bb65a18e1b 100644
--- a/net-misc/wireguard/Manifest
+++ b/net-misc/wireguard/Manifest
@@ -1 +1 @@
-DIST WireGuard-experimental-0.0.20161116.tar.xz 119836 SHA256 783a174c06c70987e43d1e1258df9e44a846b19b13395b34161fc7668259184d SHA512 f216a1e6605ed6f68d4900e440ee5ed966bb798a7e69c4e5661b1cb0460d982a2d2d16814e94da14556b9bbc36d29d17cb56c8f6ddebd56d67d2da15c6faec0c WHIRLPOOL b0d7abe03860be03c7edc5a608e5c1d8de84e82f252fbb838ebc5780851792f28f0a16d63e95233a5050cd3373a83a8222e67d433d5706cf5bc2c905b14cfb82
+DIST WireGuard-experimental-0.0.20161116.1.tar.xz 119748 SHA256 730d9d919e1942cf83e59dcb8c6ee6ac6696c62ce363c4802474774a5db8238d SHA512 abfe4e973ea5f829e90c929994f359fcc814a72d8fd92274a0921d5756ecee8b1c8e3a7b0d97947ae37915f4c7437c1cdee59ff88dc53d124fbb1a6d1f22e8d8 WHIRLPOOL 8bcfa59370240f61b2818e0509962a987fa2d1ddf87c9c0f23568edc806719a9f6293157e0d23f54a965fa81bbddee0622491c38400f11a8c128906fb47a6489
diff --git a/net-misc/wireguard/wireguard-0.0.20161116.1.ebuild b/net-misc/wireguard/wireguard-0.0.20161116.1.ebuild
new file mode 100644
index 000000000000..50d9d1c3749c
--- /dev/null
+++ b/net-misc/wireguard/wireguard-0.0.20161116.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit linux-mod
+
+DESCRIPTION="Simple yet fast and modern VPN that utilizes state-of-the-art cryptography."
+HOMEPAGE="https://www.wireguard.io/"
+
+if [[ ${PV} == 9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://git.zx2c4.com/WireGuard"
+	KEYWORDS=""
+else
+	SRC_URI="https://git.zx2c4.com/WireGuard/snapshot/WireGuard-experimental-${PV}.tar.xz"
+	S="${WORKDIR}/WireGuard-experimental-${PV}"
+	KEYWORDS="~amd64 ~x86 ~mips ~arm ~arm64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug kmod-src"
+
+DEPEND="net-libs/libmnl"
+RDEPEND="${DEPEND}"
+
+MODULE_NAMES="wireguard(net:src)"
+BUILD_PARAMS="KERNELDIR=${KERNEL_DIR} V=1"
+BUILD_TARGETS="module"
+CONFIG_CHECK="NET INET NET_UDP_TUNNEL NF_CONNTRACK NETFILTER_XT_MATCH_HASHLIMIT CRYPTO_BLKCIPHER ~PADATA ~IP6_NF_IPTABLES"
+WARNING_PADATA="If you're running a multicore system you likely should enable CONFIG_PADATA for improved performance and parallel crypto."
+WARNING_IP6_NF_IPTABLES="If your kernel has CONFIG_IPV6, you need CONFIG_IP6_NF_IPTABLES; otherwise WireGuard will not insert."
+
+pkg_setup() {
+	use kmod-src && return
+	linux-mod_pkg_setup
+	kernel_is -lt 4 1 0 && die "This version of ${PN} requires Linux >= 4.1"
+}
+
+src_compile() {
+	use debug && BUILD_PARAMS="CONFIG_WIREGUARD_DEBUG=y ${BUILD_PARAMS}"
+	use kmod-src || linux-mod_src_compile
+	emake RUNSTATEDIR="${EPREFIX}/run" -C src/tools
+}
+
+src_install() {
+	dodoc README.md
+	dodoc -r contrib/examples
+	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" -C src/tools install
+	if use kmod-src; then
+		dodir /usr/src
+		rm -r "${S}"/src/tools || die
+		mv -v "${S}"/src "${ED}"usr/src/wireguard || die
+	else
+		linux-mod_src_install
+	fi
+	insinto /$(get_libdir)/netifrc/net
+	newins "${FILESDIR}"/wireguard-openrc.sh wireguard.sh
+}
+
+pkg_postinst() {
+	if use kmod-src; then
+		einfo
+		einfo "You have enabled the kmod-src USE flag. This means that sources"
+		einfo "are installed to ${ROOT}usr/src/wireguard instead of having the"
+		einfo "kernel module compiled. You will need to compile the module"
+		einfo "yourself. Most likely, you don't want this USE flag."
+		einfo
+	else
+		linux-mod_pkg_postinst
+	fi
+	ewarn
+	ewarn "This software is experimental and has not yet been released."
+	ewarn "As such, it may contain significant issues. Please do not file"
+	ewarn "bug reports with Gentoo, but rather direct them upstream to:"
+	ewarn
+	ewarn "    team@wireguard.io    security@wireguard.io"
+	ewarn
+
+	einfo
+	einfo "After installing WireGuard, if you'd like to try sending some packets through"
+	einfo "WireGuard, you may use, for testing purposes only, the insecure client.sh"
+	einfo "test example script:"
+	einfo
+	einfo "  \$ bzcat ${ROOT}usr/share/doc/${PF}/examples/ncat-client-server/client.sh.bz2 | sudo bash -"
+	einfo
+	einfo "This will automatically setup interface wg0, through a very insecure transport"
+	einfo "that is only suitable for demonstration purposes. You can then try loading the"
+	einfo "hidden website or sending pings:"
+	einfo
+	einfo "  \$ chromium http://192.168.4.1"
+	einfo "  \$ ping 192.168.4.1"
+	einfo
+	einfo "If you'd like to redirect your internet traffic, you can run it with the"
+	einfo "\"default-route\" argument. You may not use this server for any abusive or illegal"
+	einfo "purposes. It is for quick testing only."
+	einfo
+	einfo "More info on getting started can be found at: https://www.wireguard.io/quickstart/"
+	einfo
+}
diff --git a/net-misc/wireguard/wireguard-0.0.20161116.ebuild b/net-misc/wireguard/wireguard-0.0.20161116.ebuild
deleted file mode 100644
index 50d9d1c3749c..000000000000
--- a/net-misc/wireguard/wireguard-0.0.20161116.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit linux-mod
-
-DESCRIPTION="Simple yet fast and modern VPN that utilizes state-of-the-art cryptography."
-HOMEPAGE="https://www.wireguard.io/"
-
-if [[ ${PV} == 9999 ]]; then
-	inherit git-r3
-	EGIT_REPO_URI="https://git.zx2c4.com/WireGuard"
-	KEYWORDS=""
-else
-	SRC_URI="https://git.zx2c4.com/WireGuard/snapshot/WireGuard-experimental-${PV}.tar.xz"
-	S="${WORKDIR}/WireGuard-experimental-${PV}"
-	KEYWORDS="~amd64 ~x86 ~mips ~arm ~arm64"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug kmod-src"
-
-DEPEND="net-libs/libmnl"
-RDEPEND="${DEPEND}"
-
-MODULE_NAMES="wireguard(net:src)"
-BUILD_PARAMS="KERNELDIR=${KERNEL_DIR} V=1"
-BUILD_TARGETS="module"
-CONFIG_CHECK="NET INET NET_UDP_TUNNEL NF_CONNTRACK NETFILTER_XT_MATCH_HASHLIMIT CRYPTO_BLKCIPHER ~PADATA ~IP6_NF_IPTABLES"
-WARNING_PADATA="If you're running a multicore system you likely should enable CONFIG_PADATA for improved performance and parallel crypto."
-WARNING_IP6_NF_IPTABLES="If your kernel has CONFIG_IPV6, you need CONFIG_IP6_NF_IPTABLES; otherwise WireGuard will not insert."
-
-pkg_setup() {
-	use kmod-src && return
-	linux-mod_pkg_setup
-	kernel_is -lt 4 1 0 && die "This version of ${PN} requires Linux >= 4.1"
-}
-
-src_compile() {
-	use debug && BUILD_PARAMS="CONFIG_WIREGUARD_DEBUG=y ${BUILD_PARAMS}"
-	use kmod-src || linux-mod_src_compile
-	emake RUNSTATEDIR="${EPREFIX}/run" -C src/tools
-}
-
-src_install() {
-	dodoc README.md
-	dodoc -r contrib/examples
-	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" -C src/tools install
-	if use kmod-src; then
-		dodir /usr/src
-		rm -r "${S}"/src/tools || die
-		mv -v "${S}"/src "${ED}"usr/src/wireguard || die
-	else
-		linux-mod_src_install
-	fi
-	insinto /$(get_libdir)/netifrc/net
-	newins "${FILESDIR}"/wireguard-openrc.sh wireguard.sh
-}
-
-pkg_postinst() {
-	if use kmod-src; then
-		einfo
-		einfo "You have enabled the kmod-src USE flag. This means that sources"
-		einfo "are installed to ${ROOT}usr/src/wireguard instead of having the"
-		einfo "kernel module compiled. You will need to compile the module"
-		einfo "yourself. Most likely, you don't want this USE flag."
-		einfo
-	else
-		linux-mod_pkg_postinst
-	fi
-	ewarn
-	ewarn "This software is experimental and has not yet been released."
-	ewarn "As such, it may contain significant issues. Please do not file"
-	ewarn "bug reports with Gentoo, but rather direct them upstream to:"
-	ewarn
-	ewarn "    team@wireguard.io    security@wireguard.io"
-	ewarn
-
-	einfo
-	einfo "After installing WireGuard, if you'd like to try sending some packets through"
-	einfo "WireGuard, you may use, for testing purposes only, the insecure client.sh"
-	einfo "test example script:"
-	einfo
-	einfo "  \$ bzcat ${ROOT}usr/share/doc/${PF}/examples/ncat-client-server/client.sh.bz2 | sudo bash -"
-	einfo
-	einfo "This will automatically setup interface wg0, through a very insecure transport"
-	einfo "that is only suitable for demonstration purposes. You can then try loading the"
-	einfo "hidden website or sending pings:"
-	einfo
-	einfo "  \$ chromium http://192.168.4.1"
-	einfo "  \$ ping 192.168.4.1"
-	einfo
-	einfo "If you'd like to redirect your internet traffic, you can run it with the"
-	einfo "\"default-route\" argument. You may not use this server for any abusive or illegal"
-	einfo "purposes. It is for quick testing only."
-	einfo
-	einfo "More info on getting started can be found at: https://www.wireguard.io/quickstart/"
-	einfo
-}
-- 
cgit v1.2.3-65-gdbad