From 8cbbe84b5aa98acf1136f206d4da61b47c6cf1ac Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Mon, 9 Jul 2018 08:54:09 +0200
Subject: app-cdr/gcdemu: Bump to 3.2.0

---
 app-cdr/gcdemu/Manifest            |  1 +
 app-cdr/gcdemu/gcdemu-3.2.0.ebuild | 54 ++++++++++++++++++++++++++++++++++++++
 2 files changed, 55 insertions(+)
 create mode 100644 app-cdr/gcdemu/gcdemu-3.2.0.ebuild

(limited to 'app-cdr')

diff --git a/app-cdr/gcdemu/Manifest b/app-cdr/gcdemu/Manifest
index d199d5824c7b..2e534f9ad496 100644
--- a/app-cdr/gcdemu/Manifest
+++ b/app-cdr/gcdemu/Manifest
@@ -1 +1,2 @@
 DIST gcdemu-3.1.0.tar.bz2 48036 BLAKE2B 4fc14f02a7d006556bab31b82b0cb017efec2b7e3f99854567ac0e5b8211c151583e91cf72e180341077a927430688401c4ecb6112bd6758e7288c7a06e2c4ec SHA512 e3e0369cc443bc47befa52989cc2bc5d62e4c9462bb8de1c3dd8563e1240ba7f59fc8cc54aed2e96bdb23a5f6e2fa11ca36073dfa066409f097a1dca619866fc
+DIST gcdemu-3.2.0.tar.bz2 52144 BLAKE2B f349e4482905b0ac59bce5d6af74000e05ff9b7257c7ec8755106ac8fe316d59d19de8b72705fd9cccfa888d170776667ee07fe90311a81e78f251fee85601ee SHA512 61a1775c874c9c3604ce88758039ef80b262463ae180e791eb545811fa2176e4bf07c4dbcd3be5f17d446fdef92317a0ff64ce8d27f26aeaeee9d8134b6a95ea
diff --git a/app-cdr/gcdemu/gcdemu-3.2.0.ebuild b/app-cdr/gcdemu/gcdemu-3.2.0.ebuild
new file mode 100644
index 000000000000..02e502013f61
--- /dev/null
+++ b/app-cdr/gcdemu/gcdemu-3.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="Gtk+ GUI for controlling cdemu-daemon"
+HOMEPAGE="http://cdemu.org/"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# librsvg for pixbuf-loader
+RDEPEND="${PYTHON_DEPS}
+	app-cdr/cdemu-daemon:0/7
+	dev-python/pygobject:3[${PYTHON_USEDEP}]
+	gnome-base/librsvg:2
+	x11-libs/gdk-pixbuf[introspection]
+	x11-libs/gtk+:3[introspection]
+	x11-libs/libnotify[introspection]"
+DEPEND="
+	dev-util/desktop-file-utils
+	>=dev-util/intltool-0.21
+	sys-devel/gettext
+	virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+	cmake-utils_src_prepare
+	python_fix_shebang src/gcdemu
+}
+
+src_configure() {
+	local mycmakeargs=( -DPOST_INSTALL_HOOKS=OFF )
+	cmake-utils_src_configure
+}
+
+pkg_postinst() {
+	xdg_desktop_database_update
+	gnome2_schemas_update
+}
+
+pkg_postrm() {
+	xdg_desktop_database_update
+	gnome2_schemas_update
+}
-- 
cgit v1.2.3-65-gdbad