From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 app-misc/towitoko/Manifest                 |  1 +
 app-misc/towitoko/metadata.xml             | 11 +++++++++
 app-misc/towitoko/towitoko-2.0.7-r2.ebuild | 38 ++++++++++++++++++++++++++++++
 3 files changed, 50 insertions(+)
 create mode 100644 app-misc/towitoko/Manifest
 create mode 100644 app-misc/towitoko/metadata.xml
 create mode 100644 app-misc/towitoko/towitoko-2.0.7-r2.ebuild

(limited to 'app-misc/towitoko')

diff --git a/app-misc/towitoko/Manifest b/app-misc/towitoko/Manifest
new file mode 100644
index 000000000000..5fb37fdb9676
--- /dev/null
+++ b/app-misc/towitoko/Manifest
@@ -0,0 +1 @@
+DIST towitoko-2.0.7.tar.gz 280177 SHA256 28f36954b5225dbb1729728fadaa723f49e141c5a4b77dc75d9558d787c8e660 SHA512 e2e21bda3b1dad55dee1cfb4063e114394a21973b4b2409b9dcff1479fc312fb93bf6e634d38e1f7a30e6f835d87af8268a478b534f65c916eeb13d5dbd07b86 WHIRLPOOL d3ff6aaa3c33570389ebef6d1d0648d55ea1653227e5fb0128a48f11dec5b3d42f7b9e46bdcee7c45f038c0acff66b67fe9d33ed9c7c5f8ed380e2a8a128fd19
diff --git a/app-misc/towitoko/metadata.xml b/app-misc/towitoko/metadata.xml
new file mode 100644
index 000000000000..2bda83b020a2
--- /dev/null
+++ b/app-misc/towitoko/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+  <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<use>
+  <flag name='moneyplex'>Makes libtowitoko work for the moneyplex home banking
+    software</flag>
+</use>
+</pkgmetadata>
diff --git a/app-misc/towitoko/towitoko-2.0.7-r2.ebuild b/app-misc/towitoko/towitoko-2.0.7-r2.ebuild
new file mode 100644
index 000000000000..0a2c0f45ddee
--- /dev/null
+++ b/app-misc/towitoko/towitoko-2.0.7-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+IUSE="moneyplex"
+
+DESCRIPTION="This library provides a driver for using Towitoko smartcard readers under UNIX environment"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="http://www.gentoo.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc x86"
+
+src_compile() {
+	local myconf
+
+	myconf=""
+	use moneyplex && myconf="${myconf} --disable-atr-check"
+
+	econf \
+		$(use_enable moneyplex win32-com) \
+		${myconf} || die "econf failed"
+	emake || die
+}
+
+src_install() {
+	emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+	if ! use moneyplex
+	then
+		elog "If you want to use the moneyplex home banking software from"
+		elog "http://www.matrica.de"
+		elog "then please re-emerge this package with 'moneyplex' in USE"
+	fi
+}
-- 
cgit v1.2.3-65-gdbad