From 419986192394ccf8e958dea92f251ad1d2d3fb88 Mon Sep 17 00:00:00 2001
From: Sam James <sam@gentoo.org>
Date: Sat, 13 Mar 2021 08:59:30 +0000
Subject: app-text/qpdf: add 10.3.1

Signed-off-by: Sam James <sam@gentoo.org>
---
 app-text/qpdf/Manifest           |  1 +
 app-text/qpdf/qpdf-10.3.1.ebuild | 57 ++++++++++++++++++++++++++++++++++++++++
 2 files changed, 58 insertions(+)
 create mode 100644 app-text/qpdf/qpdf-10.3.1.ebuild

(limited to 'app-text/qpdf')

diff --git a/app-text/qpdf/Manifest b/app-text/qpdf/Manifest
index 1771581f03d1..96070b521394 100644
--- a/app-text/qpdf/Manifest
+++ b/app-text/qpdf/Manifest
@@ -2,3 +2,4 @@ DIST qpdf-10.0.4.tar.gz 18465085 BLAKE2B 3b9edc38069d58d43d26b131da755b7921b7add
 DIST qpdf-10.1.0.tar.gz 18528427 BLAKE2B e62b1c8ca8d301b082cde292cb8430d6ae26433c77a30a6a21379f00cbfb3df09117d042f532f77d372d091a89a3f6581ef7d7734c67a4a1b29c1708129078f3 SHA512 f9b22d89fc62e430e6232c840ad74d220ac9eb09d7f2dfe2c42c1c943d35b5fd25e2abec9970ac19ad7ad25dc3d95c74e68e50bad395abf815cf71c432233106
 DIST qpdf-10.2.0.tar.gz 18816798 BLAKE2B 2983dd4ab8d234d6acb838abb57cd8e75edc540804608c3c3d387ee4c2f8ca8060b77e1b6f1a0950640835065fc681d9ad1dec5d8cf2a706727e237b71eabf8d SHA512 07a37aafccb670034aedfc031a4c2c1d3b6aa001e5c1bde5a3f57520a0523eebd890011a8225bb26b5beb83be15d4be3d2f1f40ad91f8370032db984cf788c0a
 DIST qpdf-10.3.0.tar.gz 18954381 BLAKE2B e0029cb1e3b8b318f0d72fa235ab08ebadb7d9479e23308398292e5374e05ae369b0fc3bbdd98554c48e55228aceb2bd8b645cbb7995cf40e21922dfd24e0485 SHA512 43afa0127d296fb314cf428403882fe200339f4620f842c129056d9498bd46574c83147e4db12405fff8ee27e0c0618ded024d46be1582ee5378c06bfae19f1f
+DIST qpdf-10.3.1.tar.gz 18956768 BLAKE2B 1581799b7bd08e28829fd26571ddaa06fc8460fd4f6935a4f69374e49c445cfcbe824175de7137817a26278c2f58d7524f6440181945064fc853f4dd30b2d528 SHA512 def94fe09770e67fe13bd3fc946667fc2935e7c448eb43602e15218e5b50f452e4f4152411f818115620e67934890c37203663537ac77ed1fcd4317e01a6d623
diff --git a/app-text/qpdf/qpdf-10.3.1.ebuild b/app-text/qpdf/qpdf-10.3.1.ebuild
new file mode 100644
index 000000000000..fa194fe13674
--- /dev/null
+++ b/app-text/qpdf/qpdf-10.3.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 Artistic-2 )"
+# subslot = libqpdf soname version
+SLOT="0/28"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris"
+IUSE="doc examples libressl ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+	net-libs/gnutls:0=
+	sys-libs/zlib
+	virtual/jpeg:0=
+	ssl? (
+		!libressl? ( dev-libs/openssl:0= )
+		libressl? ( dev-libs/libressl:0= )
+	)
+"
+DEPEND="${RDEPEND}
+	test? (
+		app-text/ghostscript-gpl[tiff(+)]
+		media-libs/tiff
+		sys-apps/diffutils
+	)
+"
+
+DOCS=( ChangeLog README.md TODO )
+
+src_configure() {
+	local myeconfargs=(
+		--disable-implicit-crypto
+		--enable-crypto-gnutls
+		--enable-crypto-native
+		--with-default-crypto=gnutls
+		--disable-static
+		$(use_enable ssl crypto-openssl)
+		$(use_enable test test-compare-images)
+	)
+	CONFIG_SHELL="${BROOT}/bin/bash" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+	default
+
+	if use examples ; then
+		dobin examples/build/.libs/*
+	fi
+
+	find "${ED}" -type f -name '*.la' -delete || die
+}
-- 
cgit v1.2.3-65-gdbad