From 4f47483fb914d08f48d0402fc01aaad0b6bbf358 Mon Sep 17 00:00:00 2001
From: Sam James <sam@gentoo.org>
Date: Sun, 24 Jan 2021 22:26:41 +0000
Subject: dev-ml/extlib: bump to 1.7.8

Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Sam James <sam@gentoo.org>
---
 dev-ml/extlib/Manifest            |  1 +
 dev-ml/extlib/extlib-1.7.8.ebuild | 53 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 54 insertions(+)
 create mode 100644 dev-ml/extlib/extlib-1.7.8.ebuild

(limited to 'dev-ml')

diff --git a/dev-ml/extlib/Manifest b/dev-ml/extlib/Manifest
index cb2f6155c622..7e70d31548e0 100644
--- a/dev-ml/extlib/Manifest
+++ b/dev-ml/extlib/Manifest
@@ -1 +1,2 @@
 DIST extlib-1.7.7.tar.gz 88870 BLAKE2B fff84524ef227718d3908c5b65f4b781360cebc0dca3a8862aa11ea671499b45192c5106769e104d396118e3cdcd904ddce06df784f8fd0eadb7a2372ca3df94 SHA512 088a6c5bbe6530cd60e2276dc02592b69ad7ad685b752f0544c54b6246b8131238c6423ce7bfc81fe3ad1766f605ecf52fd3888d55cca63e22c947afedf610c5
+DIST extlib-1.7.8.tar.gz 90213 BLAKE2B cf78d819c542e84825bea3422d1b9afb46a3f72274ac40c704ae872a5889cbe0793f1e27f2dd8f38dee118590300d3bc6a336bfd29a16dfad00008a63ceeb17c SHA512 4a0d5d82da068c34286a1547e173f2634372d01c201823edfda2b8f72d3ff58fa26da29dde9a8b2fda28989cdb655d5a9cfd71310660e5c593026a75a833e6c6
diff --git a/dev-ml/extlib/extlib-1.7.8.ebuild b/dev-ml/extlib/extlib-1.7.8.ebuild
new file mode 100644
index 000000000000..7061582188c4
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.7.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib vcs-clean
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="https://github.com/ygrek/ocaml-extlib"
+SRC_URI="https://github.com/ygrek/ocaml-extlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ocaml-${P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+
+# See bug #704146
+BDEPEND=">=dev-ml/cppo-1.6.6"
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+	default
+	egit_clean
+}
+
+src_compile() {
+	cd src || die
+	emake -j1 all
+	if use ocamlopt; then
+		emake opt cmxs
+	fi
+
+	if use doc; then
+		emake doc
+	fi
+}
+
+src_test() {
+	emake -j1 test
+}
+
+src_install() {
+	findlib_src_install
+
+	# install documentation
+	dodoc README.md
+
+	if use doc; then
+		dodoc -r src/doc/
+	fi
+}
-- 
cgit v1.2.3-65-gdbad