From 064af661d0c9a31cecdf348632bc5603333a9149 Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Tue, 10 Dec 2019 23:02:54 +0100
Subject: */*: [QA] Fix trivial cases of MissingTestRestrict
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

The result was achieved via the following pipeline:

    pkgcheck scan -c RestrictTestCheck -R FormatReporter \
      --format '{category}/{package}/{package}-{version}.ebuild' |
    xargs -n32 grep -L RESTRICT |
    xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"'

The resulting metadata was compared before and after the change.
Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip
added by the eclass.  Two ebuilds have to be fixed because of multiline
IUSE.

Suggested-by: Robin H. Johnson <robbat2@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/13942
Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-perl/HTTP-MultiPartParser/HTTP-MultiPartParser-0.20.0.ebuild | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

(limited to 'dev-perl/HTTP-MultiPartParser/HTTP-MultiPartParser-0.20.0.ebuild')

diff --git a/dev-perl/HTTP-MultiPartParser/HTTP-MultiPartParser-0.20.0.ebuild b/dev-perl/HTTP-MultiPartParser/HTTP-MultiPartParser-0.20.0.ebuild
index eed9f3c6da27..02ecba1db115 100644
--- a/dev-perl/HTTP-MultiPartParser/HTTP-MultiPartParser-0.20.0.ebuild
+++ b/dev-perl/HTTP-MultiPartParser/HTTP-MultiPartParser-0.20.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -12,6 +12,7 @@ DESCRIPTION="Low Level MultiPart MIME HTTP parser"
 SLOT="0"
 KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
 	virtual/perl-Carp
-- 
cgit v1.2.3-65-gdbad