From 8965d4b2224b3fce3f6946a943ecea4b53292477 Mon Sep 17 00:00:00 2001
From: Zac Medico <zmedico@gentoo.org>
Date: Thu, 16 Mar 2017 01:14:25 -0700
Subject: dev-python/serpent: version bump to 1.19

Package-Manager: Portage-2.3.4, Repoman-2.3.2
---
 dev-python/serpent/serpent-1.19.ebuild | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
 create mode 100644 dev-python/serpent/serpent-1.19.ebuild

(limited to 'dev-python/serpent/serpent-1.19.ebuild')

diff --git a/dev-python/serpent/serpent-1.19.ebuild b/dev-python/serpent/serpent-1.19.ebuild
new file mode 100644
index 000000000000..27e5ec56cd3d
--- /dev/null
+++ b/dev-python/serpent/serpent-1.19.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple serialization library based on ast.literal_eval"
+HOMEPAGE="https://pypi.python.org/pypi/serpent https://github.com/irmen/Serpent"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# not bundled
+RESTRICT="test"
+
+python_test() {
+	pushd "${S}"/tests >/dev/null || die
+	${PYTHON} -bb test_serpent.py || die
+	popd >/dev/null || die
+}
-- 
cgit v1.2.3-65-gdbad