From 387eddc2bbaf7d0842812933ebafec2963b4bc3e Mon Sep 17 00:00:00 2001
From: Hans de Graaff <graaff@gentoo.org>
Date: Tue, 9 Jun 2020 08:33:48 +0200
Subject: dev-ruby/bunny: fix amq-protocol dependency

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
---
 dev-ruby/bunny/bunny-2.15.0-r1.ebuild | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
 create mode 100644 dev-ruby/bunny/bunny-2.15.0-r1.ebuild

(limited to 'dev-ruby/bunny')

diff --git a/dev-ruby/bunny/bunny-2.15.0-r1.ebuild b/dev-ruby/bunny/bunny-2.15.0-r1.ebuild
new file mode 100644
index 000000000000..23b946645963
--- /dev/null
+++ b/dev-ruby/bunny/bunny-2.15.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+# Tests require a live AMQP server.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another synchronous Ruby AMQP client"
+HOMEPAGE="https://github.com/celldee/bunny"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/amq-protocol-2.3.1:2"
+
+all_ruby_install() {
+	all_fakegem_install
+
+	dodoc -r examples
+}
-- 
cgit v1.2.3-65-gdbad