From 34b62e6594e4c384657095bb7a0ceca69d8a707b Mon Sep 17 00:00:00 2001
From: Sam James <sam@gentoo.org>
Date: Tue, 6 Apr 2021 02:09:01 +0100
Subject: games-fps/glxquake-bin: port to EAPI 7, games.eclass--, improve
 pkg_postinst

Signed-off-by: Sam James <sam@gentoo.org>
---
 games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild | 42 -------------------------
 games-fps/glxquake-bin/glxquake-bin-0-r3.ebuild | 40 +++++++++++++++++++++++
 2 files changed, 40 insertions(+), 42 deletions(-)
 delete mode 100644 games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild
 create mode 100644 games-fps/glxquake-bin/glxquake-bin-0-r3.ebuild

(limited to 'games-fps')

diff --git a/games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild b/games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild
deleted file mode 100644
index 14f81de25338..000000000000
--- a/games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit games
-
-DESCRIPTION="A binary that works with any 3D-graphics-card that supports the glx X-extension"
-HOMEPAGE="http://mfcn.ilo.de/glxquake/"
-SRC_URI="http://www.wh-hms.uni-ulm.de/~mfcn/shared/glxquake/glxquake.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-RESTRICT="strip"
-IUSE=""
-
-RDEPEND="sys-libs/glibc
-	amd64? ( sys-libs/glibc[multilib] )
-	virtual/opengl[abi_x86_32(-)]
-	x11-libs/libX11[abi_x86_32(-)]
-	x11-libs/libXext[abi_x86_32(-)]
-	x11-libs/libXxf86vm[abi_x86_32(-)]
-	x11-libs/libXxf86dga[abi_x86_32(-)]"
-
-S=${WORKDIR}/glxquake
-
-QA_PREBUILT="${GAMES_BINDIR:1}/glquake"
-
-src_install() {
-	dogamesbin glquake
-	dodoc README
-	prepgamesdirs
-}
-
-pkg_postinst() {
-	games_pkg_postinst
-	elog "To play with it, create a subdirectory called id1"
-	elog "Copy the pak0.pak, and eventually pak1.pak into this subdirectory"
-	elog "You can eventually get pak0.pak emerging games-fps/quake1-demodata"
-	elog "The file pak0.pak will be on the ${GAMES_DATADIR}/quake1/demo/"
-	elog "You can now run glxquake by executing glquake"
-}
diff --git a/games-fps/glxquake-bin/glxquake-bin-0-r3.ebuild b/games-fps/glxquake-bin/glxquake-bin-0-r3.ebuild
new file mode 100644
index 000000000000..eb9cce08a4ba
--- /dev/null
+++ b/games-fps/glxquake-bin/glxquake-bin-0-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A binary that works with any 3D-graphics-card that supports the glx X-extension"
+HOMEPAGE="http://mfcn.ilo.de/glxquake/"
+SRC_URI="http://www.wh-hms.uni-ulm.de/~mfcn/shared/glxquake/glxquake.tar.gz"
+S="${WORKDIR}"/glxquake
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="strip"
+
+RDEPEND="
+	sys-libs/glibc
+	amd64? ( sys-libs/glibc[multilib] )
+	virtual/opengl[abi_x86_32(-)]
+	x11-libs/libX11[abi_x86_32(-)]
+	x11-libs/libXext[abi_x86_32(-)]
+	x11-libs/libXxf86vm[abi_x86_32(-)]
+	x11-libs/libXxf86dga[abi_x86_32(-)]
+"
+
+QA_PREBUILT="usr/bin/glquake"
+
+src_install() {
+	dobin glquake
+	dodoc README
+}
+
+pkg_postinst() {
+	elog "To play with ${PN}, create a subdirectory called id1"
+	elog "Copy the pak0.pak, and eventually pak1.pak into this subdirectory"
+	elog "You can get pak0.pa by emerging games-fps/quake1-demodata"
+	elog "(or use the disc)"
+	elog "The file pak0.pak will be in /usr/share/quake1/demo/"
+	elog "You can now run glxquake by executing glquake"
+}
-- 
cgit v1.2.3-65-gdbad