From 6ada805286db1e9e4ba661532805840618ae7973 Mon Sep 17 00:00:00 2001
From: NP-Hardass <NP-Hardass@gentoo.org>
Date: Sun, 3 Jun 2018 12:01:40 -0400
Subject: games-strategy/freeorion: Backport fix for detecting SDL2 incl dir

Closes: https://bugs.gentoo.org/651762
Package-Manager: Portage-2.3.36, Repoman-2.3.9
---
 ...ion-0.4.7.1-backport-sdl2-include-dir-fix.patch | 34 +++++++++
 .../freeorion/freeorion-0.4.7.1-r4.ebuild          | 85 ++++++++++++++++++++++
 2 files changed, 119 insertions(+)
 create mode 100644 games-strategy/freeorion/files/freeorion-0.4.7.1-backport-sdl2-include-dir-fix.patch
 create mode 100644 games-strategy/freeorion/freeorion-0.4.7.1-r4.ebuild

(limited to 'games-strategy')

diff --git a/games-strategy/freeorion/files/freeorion-0.4.7.1-backport-sdl2-include-dir-fix.patch b/games-strategy/freeorion/files/freeorion-0.4.7.1-backport-sdl2-include-dir-fix.patch
new file mode 100644
index 000000000000..f7ccdba126bb
--- /dev/null
+++ b/games-strategy/freeorion/files/freeorion-0.4.7.1-backport-sdl2-include-dir-fix.patch
@@ -0,0 +1,34 @@
+From 77bdc407d0760a529e40914d16248dce01fd4778 Mon Sep 17 00:00:00 2001
+From: O01eg <o01eg@yandex.ru>
+Date: Wed, 8 Nov 2017 16:07:57 +0300
+Subject: [PATCH] Fix #1843
+
+---
+ CMakeLists.txt    | 2 +-
+ GG/CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+--- a/CMakeLists.txt	2018-06-03 11:36:04.631832409 -0400
++++ b/CMakeLists.txt	2018-06-03 11:36:20.678821846 -0400
+@@ -484,7 +484,7 @@
+         ${Boost_INCLUDE_DIRS}
+         ${OPENGL_INCLUDE_DIR}
+         ${GLEW_INCLUDE_DIRS}
+-        ${SDL_INCLUDE_DIRS}
++        ${SDL_INCLUDE_DIR}
+         ${OPENAL_INCLUDE_DIR}
+         ${OGG_INCLUDE_DIRS}
+         ${VORBIS_INCLUDE_DIRS}
+diff --git a/GG/CMakeLists.txt b/GG/CMakeLists.txt
+index 5d3c157362..c5bf3825d8 100644
+--- a/GG/CMakeLists.txt
++++ b/GG/CMakeLists.txt
+@@ -184,7 +184,7 @@ target_include_directories(GiGiSDL SYSTEM
+         ${Boost_INCLUDE_DIRS}
+         ${OPENGL_INCLUDE_DIR}
+         ${GLEW_INCLUDE_DIRS}
+-        ${SDL_INCLUDE_DIRS}
++        ${SDL_INCLUDE_DIR}
+ )
+ 
+ target_link_libraries(GiGiSDL
diff --git a/games-strategy/freeorion/freeorion-0.4.7.1-r4.ebuild b/games-strategy/freeorion/freeorion-0.4.7.1-r4.ebuild
new file mode 100644
index 000000000000..e3471161e466
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-0.4.7.1-r4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils python-single-r1 gnome2-utils
+
+DESCRIPTION="A free turn-based space empire and galactic conquest game"
+HOMEPAGE="http://www.freeorion.org"
+
+if [[ ${PV} == 9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/freeorion/freeorion.git"
+else
+	MY_PV="${PV/_/-}"
+	SRC_URI="https://github.com/${PN}/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64"
+	S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="GPL-2 LGPL-2.1 CC-BY-SA-3.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+	>=dev-libs/boost-1.56:=[python,threads,${PYTHON_USEDEP}]
+	media-libs/freealut
+	media-libs/freetype
+	media-libs/glew:=
+	media-libs/libsdl2
+	>=media-libs/libogg-1.1.3
+	media-libs/libpng:0
+	media-libs/libsdl2[X,opengl,video]
+	>=media-libs/libvorbis-1.1.2
+	media-libs/openal
+	sci-physics/bullet
+	sys-libs/zlib
+	virtual/opengl
+	!dev-games/gigi"
+	# Use bundled gigi as of freeorion-0.4.3
+
+DEPEND="${RDEPEND}
+	${PYTHON_DEPS}
+	virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-backport-sdl2-include-dir-fix.patch" )
+
+pkg_setup() {
+	# build system is using FindPythonLibs.cmake which needs python:2
+	python-single-r1_pkg_setup
+}
+
+src_prepare() {
+	sed -e "s/-O3//" -i CMakeLists.txt || die
+
+	cmake-utils_src_prepare
+}
+
+src_configure() {
+	local mycmakeargs=(
+		-DCMAKE_BUILD_TYPEE=Release
+		-DRELEASE_COMPILE_FLAGS=""
+		-DCMAKE_SKIP_RPATH=ON
+	)
+
+	append-cppflags -DBOOST_OPTIONAL_CONFIG_USE_OLD_IMPLEMENTATION_OF_OPTIONAL
+
+	cmake-utils_src_configure
+}
+
+src_install() {
+	cmake-utils_src_install
+	dodoc ChangeLog.md
+
+	newenvd "${FILESDIR}/${PN}.envd" 99${PN}
+}
+
+pkg_postinst() {
+	gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+	gnome2_icon_cache_update
+}
-- 
cgit v1.2.3-65-gdbad