From 381859713aa94bc36e5e4dffe65671e4f3f3adf5 Mon Sep 17 00:00:00 2001
From: David Seifert <soap@gentoo.org>
Date: Thu, 4 Feb 2016 20:35:02 +0100
Subject: media-libs/phat: Fix underlinking with x11-libs/libX11

* EAPI=6
* Change SRC_URI and HOMEPAGE (Gentoo-Bug: 537756)
* Add missing dev-util/gtk-doc for autoreconf

Package-Manager: portage-2.2.27
---
 .../phat/files/phat-0.4.1-underlinking.patch       | 27 ++++++++++++++
 media-libs/phat/phat-0.4.1-r1.ebuild               | 43 ++++++++++++++++++++++
 2 files changed, 70 insertions(+)
 create mode 100644 media-libs/phat/files/phat-0.4.1-underlinking.patch
 create mode 100644 media-libs/phat/phat-0.4.1-r1.ebuild

(limited to 'media-libs/phat')

diff --git a/media-libs/phat/files/phat-0.4.1-underlinking.patch b/media-libs/phat/files/phat-0.4.1-underlinking.patch
new file mode 100644
index 000000000000..d841cd07468b
--- /dev/null
+++ b/media-libs/phat/files/phat-0.4.1-underlinking.patch
@@ -0,0 +1,27 @@
+- Remove hardcoded CFLAGS and -Werror flags
+- Fix underlinking caused by missing x11 dependency:
+* ../phat/.libs/libphat.so: error: undefined reference to 'XWarpPointer'
+
+--- phat-0.4.1/configure.ac
++++ phat-0.4.1/configure.ac
+@@ -17,7 +17,6 @@
+     [if test x$enable_debug = xyes; then with_debug=yes ; fi])
+ 
+ if test x$with_debug = xno; then
+-    CFLAGS="-O3"
+     AC_DEFINE(DEBUG, 0, [[whether to display debugging output or not]])
+ else
+     AC_DEFINE(DEBUG, 1, [[whether to display debugging output or not]])
+@@ -46,10 +45,10 @@
+ GTK_DOC_CHECK(1.0)
+ 
+ # misc checks
+-PKG_CHECK_MODULES(MISC, libgnomecanvas-2.0)
++PKG_CHECK_MODULES(MISC, libgnomecanvas-2.0 x11)
+ 
+ # set compilation flags
+-CFLAGS="$CFLAGS $GTK_CFLAGS $MISC_CFLAGS -Wall -Werror"
++CFLAGS="$CFLAGS $GTK_CFLAGS $MISC_CFLAGS -Wall"
+ LIBS="$LIBS $GTK_LIBS $MISC_LIBS"
+ 
+ # print build summary
diff --git a/media-libs/phat/phat-0.4.1-r1.ebuild b/media-libs/phat/phat-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..cabb3f35a46c
--- /dev/null
+++ b/media-libs/phat/phat-0.4.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="PHAT is a collection of GTK+ widgets geared toward pro-audio apps"
+HOMEPAGE="https://sourceforge.net/projects/phat.berlios/"
+SRC_URI="mirror://sourceforge/phat.berlios/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/gtk+:2
+	x11-libs/libX11
+	gnome-base/libgnomecanvas"
+DEPEND="${RDEPEND}
+	virtual/pkgconfig
+	dev-util/gtk-doc"
+
+PATCHES=(
+	"${FILESDIR}/${P}-underlinking.patch"
+)
+
+src_prepare() {
+	default
+	eautoreconf
+}
+
+src_configure() {
+	econf \
+		--disable-static \
+		$(use_enable debug)
+}
+
+src_install() {
+	default
+	prune_libtool_files --all
+}
-- 
cgit v1.2.3-65-gdbad