From 71641b70c6c22d1985d59caaec63c98914864ce6 Mon Sep 17 00:00:00 2001
From: Alexis Ballier <aballier@gentoo.org>
Date: Fri, 6 Nov 2015 08:08:59 +0100
Subject: media-sound/lmms: fix build with gcc 5.2

Package-Manager: portage-2.2.24
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
---
 media-sound/lmms/files/gcc52.patch | 25 +++++++++++++++++++++++++
 media-sound/lmms/lmms-1.1.3.ebuild |  2 ++
 2 files changed, 27 insertions(+)
 create mode 100644 media-sound/lmms/files/gcc52.patch

(limited to 'media-sound')

diff --git a/media-sound/lmms/files/gcc52.patch b/media-sound/lmms/files/gcc52.patch
new file mode 100644
index 000000000000..60892a717eba
--- /dev/null
+++ b/media-sound/lmms/files/gcc52.patch
@@ -0,0 +1,25 @@
+commit 317b2f02a829f694a66c760fc6de7df1db99b006
+Author: Tobias Doerffel <tobias.doerffel@gmail.com>
+Date:   Mon Feb 16 18:22:49 2015 +0100
+
+    AutomatableModel: fix wrong comparison logic
+    
+    We must not negate the float but instead test for inequality in order to
+    determine whether the linked model has to be updated.
+    
+    Closes #1761.
+
+diff --git a/src/core/AutomatableModel.cpp b/src/core/AutomatableModel.cpp
+index 6c7501c..bf56285 100644
+--- a/src/core/AutomatableModel.cpp
++++ b/src/core/AutomatableModel.cpp
+@@ -318,8 +318,7 @@ void AutomatableModel::setAutomatedValue( const float value )
+ 									it != m_linkedModels.end(); ++it )
+ 		{
+ 			if( (*it)->m_setValueDepth < 1 &&
+-				!(*it)->fittedValue( m_value ) !=
+-							 (*it)->m_value )
++				(*it)->fittedValue( m_value ) != (*it)->m_value )
+ 			{
+ 				(*it)->setAutomatedValue( value );
+ 			}
diff --git a/media-sound/lmms/lmms-1.1.3.ebuild b/media-sound/lmms/lmms-1.1.3.ebuild
index db9a5060802a..8167c4c26bf1 100644
--- a/media-sound/lmms/lmms-1.1.3.ebuild
+++ b/media-sound/lmms/lmms-1.1.3.ebuild
@@ -44,6 +44,8 @@ RDEPEND="${RDEPEND}
 
 DOCS="README AUTHORS TODO"
 
+PATCHES=( "${FILESDIR}/gcc52.patch" )
+
 src_configure() {
 	mycmakeargs="${mycmakeargs}
 		-DWANT_SYSTEM_SR=TRUE
-- 
cgit v1.2.3-65-gdbad