From 5a2537beeb122e7f54338283c7bf3b3f6b1e17e4 Mon Sep 17 00:00:00 2001
From: Alexis Ballier <aballier@gentoo.org>
Date: Sat, 14 Nov 2015 12:54:49 +0100
Subject: media-video/ffmpeg;: Add mmal useflag. Bug #565298.

Package-Manager: portage-2.2.24
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
---
 media-video/ffmpeg/ffmpeg-9999.ebuild | 3 ++-
 media-video/ffmpeg/metadata.xml       | 1 +
 2 files changed, 3 insertions(+), 1 deletion(-)

(limited to 'media-video')

diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index f84cadd913ed..bbc2f79a8f00 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -75,7 +75,7 @@ FFMPEG_FLAG_MAP=(
 		# decoders
 		amr:libopencore-amrwb amr:libopencore-amrnb fdk:libfdk-aac
 		jpeg2k:libopenjpeg bluray:libbluray celt:libcelt gme:libgme gsm:libgsm
-		modplug:libmodplug opus:libopus quvi:libquvi librtmp ssh:libssh
+		mmal modplug:libmodplug opus:libopus quvi:libquvi librtmp ssh:libssh
 		schroedinger:libschroedinger speex:libspeex vorbis:libvorbis vpx:libvpx
 		zvbi:libzvbi
 		# libavfilter options
@@ -208,6 +208,7 @@ RDEPEND="
 	libsoxr? ( >=media-libs/soxr-0.1.0[${MULTILIB_USEDEP}] )
 	libv4l? ( >=media-libs/libv4l-0.9.5[${MULTILIB_USEDEP}] )
 	lzma? ( >=app-arch/xz-utils-5.0.5-r1[${MULTILIB_USEDEP}] )
+	mmal? ( media-libs/raspberrypi-userland )
 	modplug? ( >=media-libs/libmodplug-0.8.8.4-r1[${MULTILIB_USEDEP}] )
 	openal? ( >=media-libs/openal-1.15.1[${MULTILIB_USEDEP}] )
 	opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 53adfacfd2d3..1bb06e4ba6d4 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -35,6 +35,7 @@
 	<flag name="mipsdspr1">Enables MIPS DSP ASE R1 optimizations.</flag>
 	<flag name="mipsdspr2">Enables MIPS DSP ASE R2 optimizations.</flag>
 	<flag name="mipsfpu">Enables floating point MIPS optimizations.</flag>
+	<flag name="mmal">Enables Multi-Media Abstraction Layer (MMAL) decoding support: Available e.g. on the Raspberry Pi.</flag>
 	<flag name="network">Enables network streaming support</flag>
 	<flag name="nvenc">Adds support for NVIDIA Encoder (NVENC) API for hardware accelerated encoding on NVIDIA cards.</flag>
 	<flag name="openh264">Enables H.264 encoding suppoprt via <pkg>media-libs/openh264</pkg>.</flag>
-- 
cgit v1.2.3-65-gdbad