From ec1818b8687b95b047ae776509f4f0e7095c0b93 Mon Sep 17 00:00:00 2001
From: Jeroen Roovers <jer@gentoo.org>
Date: Tue, 21 Mar 2017 06:25:19 +0100
Subject: net-misc/youtube-dl: Version bump.

Package-Manager: Portage-2.3.5, Repoman-2.3.2
---
 net-misc/youtube-dl/Manifest                     |  1 +
 net-misc/youtube-dl/youtube-dl-2017.03.20.ebuild | 98 ++++++++++++++++++++++++
 2 files changed, 99 insertions(+)
 create mode 100644 net-misc/youtube-dl/youtube-dl-2017.03.20.ebuild

(limited to 'net-misc/youtube-dl')

diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index aaefe866d1db..17078e07dd7d 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
 DIST youtube-dl-2016.12.22.tar.gz 2502964 SHA256 f5bc5eb1af17391b7a1da795f4181c3702fb2c1da2668b25f1260dbdba882524 SHA512 87fee134da660a4feb4cfcd2cbb35cb9682e6ed08c766e3c89f6c986f991cac78c64f5bf8a1d15c4080e4df0909c6a360137407a7896b93f8f41cf4493f341cb WHIRLPOOL 6909d34958e4152be3334723c68d207bb34db2996d90908829ebd3ee45d28768d7f6cba8ce0fb19de440b34fb96b46b3d5b8bf830c998037c4f4d59e574206c3
 DIST youtube-dl-2017.03.10.tar.gz 2628943 SHA256 4401089cdc71f5767a9fee5c6edbf9e14238cfd61934dd74ed277ce61fe49931 SHA512 cdebb72d3bb05c773c4bd6e689d654192ab752ba4f4eb023b60e06c6181f827b096ce3c27181f6f6b19e559bf91e6e1e6d3e08fef5ae8866d4db08489f77f47f WHIRLPOOL 0d01e503c072d495c023d851e6814659476ad14416eef646ca997593e51d1ebc787db67a04130b640f6c29e00fa27554b0de342690ba880168434cb16f67e453
 DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
+DIST youtube-dl-2017.03.20.tar.gz 2643811 SHA256 6e4201d7b45da75e9ed04c0393e9b1ce86fad27375337d5e1700549a26597215 SHA512 96c4023d30e22088ff32ad0b7c23566b0c90937b4054d98a22f98cb032bc094738e3830e2e0377856800f0fa742095b43f186ea40fece85555720d281e1f0915 WHIRLPOOL 776711d09e927c11dff8e3c83270456a8ca20b97fa92c9f9d88b148aa3a5e8908b51069ac9aecdfadd8476dd3ab94e9eb2b3768f1a5558e87d5a3fa4b7dc88cb
diff --git a/net-misc/youtube-dl/youtube-dl-2017.03.20.ebuild b/net-misc/youtube-dl/youtube-dl-2017.03.20.ebuild
new file mode 100644
index 000000000000..974ca7615e84
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.03.20.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+	dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+	${RDEPEND}
+	test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+	if ! use offensive; then
+		sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+			youtube_dl/version.py || die
+		# these have single line import statements
+		local xxx=(
+			alphaporno anysex behindkink camwithher chaturbate eporner
+			eroprofile extremetube fourtube foxgay goshgay hellporno
+			hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+			myvidster porn91 pornflip porncom pornhd pornotube pornovoisines
+			pornoxo ruleporn sexu slutload spankbang spankwire sunporno thisav
+			tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+			youjizz youporn
+		)
+		# these have multi-line import statements
+		local mxxx=(
+			drtuber pornhub redtube xhamster tnaflix
+		)
+		# do single line imports
+		sed -i \
+			-e $( printf '/%s/d;' ${xxx[@]} ) \
+			youtube_dl/extractor/extractors.py \
+			|| die
+
+		# do multiple line imports
+		sed -i \
+			-e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+			youtube_dl/extractor/extractors.py \
+			|| die
+
+		sed -i \
+			-e $( printf '/%s/d;' ${mxxx[@]} ) \
+			youtube_dl/extractor/generic.py \
+			|| die
+
+		rm \
+			$( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+			$( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+			test/test_age_restriction.py \
+			|| die
+	fi
+
+	epatch_user
+
+	distutils-r1_python_prepare_all
+}
+
+src_compile() {
+	distutils-r1_src_compile
+}
+
+python_test() {
+	emake test
+}
+
+python_install_all() {
+	dodoc README.txt
+	doman ${PN}.1
+
+	newbashcomp ${PN}.bash-completion ${PN}
+
+	insinto /usr/share/zsh/site-functions
+	newins youtube-dl.zsh _youtube-dl
+
+	insinto /usr/share/fish/completions
+	doins youtube-dl.fish
+
+	distutils-r1_python_install_all
+
+	rm -r "${ED}"/usr/etc || die
+}
-- 
cgit v1.2.3-65-gdbad