From c6dd328c2de4c30494d9c3ff28a6aa76dad48294 Mon Sep 17 00:00:00 2001
From: Sam James <sam@gentoo.org>
Date: Thu, 24 Nov 2022 01:09:29 +0000
Subject: sys-block/devio: fix configure w/ clang 16

Signed-off-by: Sam James <sam@gentoo.org>
---
 sys-block/devio/devio-1.2-r1.ebuild | 21 +++++++++++++++++++++
 sys-block/devio/devio-1.2.ebuild    | 12 ------------
 2 files changed, 21 insertions(+), 12 deletions(-)
 create mode 100644 sys-block/devio/devio-1.2-r1.ebuild
 delete mode 100644 sys-block/devio/devio-1.2.ebuild

(limited to 'sys-block')

diff --git a/sys-block/devio/devio-1.2-r1.ebuild b/sys-block/devio/devio-1.2-r1.ebuild
new file mode 100644
index 000000000000..62241d9573f7
--- /dev/null
+++ b/sys-block/devio/devio-1.2-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Correctly read (or write) a region of a block device"
+HOMEPAGE="http://devio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/devio/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 arm x86"
+
+src_prepare() {
+	default
+
+	# Clang 16
+	eautoreconf
+}
diff --git a/sys-block/devio/devio-1.2.ebuild b/sys-block/devio/devio-1.2.ebuild
deleted file mode 100644
index e726f3424a48..000000000000
--- a/sys-block/devio/devio-1.2.ebuild
+++ /dev/null
@@ -1,12 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="correctly read (or write) a region of a block device"
-HOMEPAGE="http://devio.sourceforge.net/"
-SRC_URI="mirror://sourceforge/devio/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 arm x86"
-- 
cgit v1.2.3-65-gdbad