From 7d1cae050f32e59fcda0f629017af706a5f135b7 Mon Sep 17 00:00:00 2001
From: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Date: Wed, 1 Aug 2018 18:47:03 +0200
Subject: sys-fs/copyfs: EAPI7, improve ebuild

Bug: https://bugs.gentoo.org/648050
---
 sys-fs/copyfs/copyfs-1.0.1-r1.ebuild | 42 ++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
 create mode 100644 sys-fs/copyfs/copyfs-1.0.1-r1.ebuild

(limited to 'sys-fs/copyfs')

diff --git a/sys-fs/copyfs/copyfs-1.0.1-r1.ebuild b/sys-fs/copyfs/copyfs-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..ec53bab73be8
--- /dev/null
+++ b/sys-fs/copyfs/copyfs-1.0.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="fuse-based filesystem for maintaining configuration files"
+HOMEPAGE="https://boklm.eu/copyfs/"
+SRC_URI="https://boklm.eu/copyfs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=sys-fs/fuse-2.0:0"
+DEPEND="${RDEPEND}
+	sys-apps/attr"
+
+PATCHES=(
+	# this patch fixes sandbox violations
+	"${FILESDIR}"/${P}-gentoo.patch
+	# this patch adds support for cleaning up the versions directory
+	# the patch is experimental at best, but it's better than your
+	# versions directory filling up with unused files
+	#
+	# patch by stuart@gentoo.org
+	"${FILESDIR}"/${PN}-1.0-unlink.patch
+)
+
+src_prepare() {
+	default
+	eautoreconf
+}
+
+src_configure() {
+	econf --bindir="${D}/usr/bin" --mandir="${D}/usr/share/man"
+}
+
+src_compile() {
+	emake CC=$(tc-getCC)
+}
-- 
cgit v1.2.3-65-gdbad