summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2022-01-12 05:47:56 +0100
committerMartin Väth <martin@mvath.de>2022-01-12 05:47:56 +0100
commitc4d006afe68064d2176ff274dc85102098b712ec (patch)
treedb428fe01e595cf121a22c9b04989d3d7b4c1643
parentmedia-video/pipewire x11-libs/gtk+: Version bump. media-video/handbrake: remove (diff)
downloadmv-c4d006afe68064d2176ff274dc85102098b712ec.tar.gz
mv-c4d006afe68064d2176ff274dc85102098b712ec.tar.bz2
mv-c4d006afe68064d2176ff274dc85102098b712ec.zip
acct-{group,user} for flexlm trackballs noip-updater schedule
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--acct-group/flexlm/flexlm-0.ebuild17
-rw-r--r--acct-group/schedule/schedule-0.ebuild17
-rw-r--r--acct-user/flexlm/flexlm-0.ebuild18
-rw-r--r--acct-user/schedule/schedule-0.ebuild18
-rw-r--r--app-admin/flexlm/flexlm-9.5-r3.ebuild (renamed from app-admin/flexlm/flexlm-9.5-r2.ebuild)10
-rw-r--r--games-action/trackballs/trackballs-1.1.4-r2.ebuild (renamed from games-action/trackballs/trackballs-1.1.4-r1.ebuild)13
-rw-r--r--metadata/pkg_desc_index12
-rw-r--r--net-dns/noip-updater/noip-updater-2.1.9-r6.ebuild (renamed from net-dns/noip-updater/noip-updater-2.1.9-r5.ebuild)12
-rw-r--r--sys-apps/schedule/schedule-8.0.1-r1.ebuild (renamed from sys-apps/schedule/schedule-8.0.1.ebuild)15
9 files changed, 100 insertions, 32 deletions
diff --git a/acct-group/flexlm/flexlm-0.ebuild b/acct-group/flexlm/flexlm-0.ebuild
new file mode 100644
index 00000000..b19d8b07
--- /dev/null
+++ b/acct-group/flexlm/flexlm-0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2022 Martin V\"ath
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit user
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT=0
+DESCRIPTION="Group for app-admin/flexlm"
+HOMEPAGE=
+SRC_URI=
+LICENSE=
+IUSE=
+
+pkg_postinst() {
+ enewgroup flexlm
+}
diff --git a/acct-group/schedule/schedule-0.ebuild b/acct-group/schedule/schedule-0.ebuild
new file mode 100644
index 00000000..aef6d7d3
--- /dev/null
+++ b/acct-group/schedule/schedule-0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2022 Martin V\"ath
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit user
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT=0
+DESCRIPTION="Group for sys-apps/schedule"
+HOMEPAGE=
+SRC_URI=
+LICENSE=
+IUSE=
+
+pkg_postinst() {
+ use prefix || enewgroup schedule
+}
diff --git a/acct-user/flexlm/flexlm-0.ebuild b/acct-user/flexlm/flexlm-0.ebuild
new file mode 100644
index 00000000..c4618443
--- /dev/null
+++ b/acct-user/flexlm/flexlm-0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2022 Martin V\"ath
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit user
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT=0
+DESCRIPTION="User for app-admin/flexlm"
+HOMEPAGE=
+SRC_URI=
+LICENSE=
+IUSE=
+DEPEND="acct-group/schedule"
+
+pkg_postinst() {
+ enewuser flexlm -1 /bin/bash /opt/flexlm flexlm
+}
diff --git a/acct-user/schedule/schedule-0.ebuild b/acct-user/schedule/schedule-0.ebuild
new file mode 100644
index 00000000..e3145b19
--- /dev/null
+++ b/acct-user/schedule/schedule-0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2022 Martin V\"ath
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit user
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT=0
+DESCRIPTION="User for sys-apps/schedule"
+HOMEPAGE=
+SRC_URI=
+LICENSE=
+IUSE=
+DEPEND="acct-group/schedule"
+
+pkg_postinst() {
+ use prefix || enewuser schedule -1 -1 -1 schedule
+}
diff --git a/app-admin/flexlm/flexlm-9.5-r2.ebuild b/app-admin/flexlm/flexlm-9.5-r3.ebuild
index e14ddd58..3295a668 100644
--- a/app-admin/flexlm/flexlm-9.5-r2.ebuild
+++ b/app-admin/flexlm/flexlm-9.5-r3.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2018 Gentoo Authors and Martin V\"ath
+# Copyright 1999-2022 Gentoo Authors and Martin V\"ath
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
RESTRICT="fetch"
-inherit user
DESCRIPTION="Macrovision FLEXlm license manager and utils"
HOMEPAGE="http://www.macrovision.com/services/support/flexlm/lmgrd.shtml"
@@ -22,6 +21,8 @@ LICENSE="all-rights-reserved GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
+DEPEND="acct-group/flexlm
+ acct-user/flexlm"
QA_PREBUILT="
opt/flexlm/bin/lmgrd
@@ -66,9 +67,6 @@ src_install () {
}
pkg_postinst() {
- enewgroup flexlm
- enewuser flexlm -1 /bin/bash /opt/flexlm flexlm
-
# See bug 383787
chown flexlm /var/log/flexlm || eerror "'chown flexlm /var/log/flexlm' failed!"
diff --git a/games-action/trackballs/trackballs-1.1.4-r1.ebuild b/games-action/trackballs/trackballs-1.1.4-r2.ebuild
index 82be4a34..439b7551 100644
--- a/games-action/trackballs/trackballs-1.1.4-r1.ebuild
+++ b/games-action/trackballs/trackballs-1.1.4-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2016-2018 Gentoo Authors and Martin V\"ath
+# Copyright 2016-2022 Gentoo Authors and Martin V\"ath
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit desktop user
+EAPI=8
+inherit desktop
RESTRICT="mirror"
DESCRIPTION="simple game similar to the classical game Marble Madness"
@@ -23,13 +23,10 @@ RDEPEND="virtual/opengl
media-libs/sdl-image
media-libs/sdl-ttf
nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ acct-group/gamestat"
BDEPEND="nls? ( sys-devel/gettext )"
-pkg_setup(){
- enewgroup gamestat 36
-}
-
src_prepare() {
sed -i \
-e 's/icons //' \
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 9da3b7e1..8fd2b0ea 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -1,4 +1,8 @@
-app-admin/flexlm 9.5-r2: Macrovision FLEXlm license manager and utils
+acct-group/flexlm 0: Group for app-admin/flexlm
+acct-group/schedule 0: Group for sys-apps/schedule
+acct-user/flexlm 0: User for app-admin/flexlm
+acct-user/schedule 0: User for sys-apps/schedule
+app-admin/flexlm 9.5-r3: Macrovision FLEXlm license manager and utils
app-admin/sudox 10.0: wrapper for sudo which can pass X authority data and deal with screen and tmux
app-arch/archwrap 11.4: A collection of POSIX shell scripts to invoke archiver programs
app-arch/bzwc 5.1: A POSIX shell wrapper for wc, supporting compressed files (xz, lzma, bz2, gz)
@@ -61,7 +65,7 @@ dev-util/mv_perl 4.3: A collection of perl scripts (replacement in files, syncin
dev-util/pyrep 1.5-r1: Search and/or replace regular expressions within many files interactively
dev-util/replacer 3.3: Search and replace python regular expressions within many files interactively
dev-vcs/git-wrappers-mv 2.3: Some personal wrappers for the most important git commands
-games-action/trackballs 1.1.4-r1: simple game similar to the classical game Marble Madness
+games-action/trackballs 1.1.4-r2: simple game similar to the classical game Marble Madness
games-board/chessproblem 1.10 2.13: Find solutions of chess problems (mate, selfmate, and helpmate) with cooks
games-emulation/sdlmame 0.174-r2: Multiple Arcade Machine Emulator + Multi Emulator Super System (MESS)
games-emulation/xmame 0.106-r4: Multiple Arcade Machine Emulator for X11
@@ -86,7 +90,7 @@ media-video/video-mv 17.1: Frontends for using mplayer/mencoder, ffmpeg/libav, o
net-dialup/accounting 1.60.45.3.1-r1: Give statistics about dialup connections. Originally part of SuSE's smpppd
net-dialup/martian-modem 20100123-r3: ltmodem alternative driver providing support for Agere Systems winmodems
net-dns/host 20070128-r1: A powerful command-line DNS query and test tool
-net-dns/noip-updater 2.1.9-r5: no-ip.com dynamic DNS updater
+net-dns/noip-updater 2.1.9-r6: no-ip.com dynamic DNS updater
net-firewall/firewall-mv 13.2: Initialize iptables and net-related sysctl variables
net-misc/netctl 1.11: Profile based network connection tool from Arch Linux
net-misc/openrdate 1.2: use TCP or UDP to retrieve the current time of another machine
@@ -100,7 +104,7 @@ sys-apps/less 590: Excellent text file viewer, optionally with additional select
sys-apps/man 1.6g-r4: Standard commands to read man pages
sys-apps/openrc-wrapper 2.4: Use openrc init scripts with systemd or other init systems
sys-apps/paxopen 1.2: A wrapper script to set PAX kernel variables to an insecure/safe state
-sys-apps/schedule 8.0.1: script to schedule jobs in a multiuser multitasking environment
+sys-apps/schedule 8.0.1-r1: script to schedule jobs in a multiuser multitasking environment
sys-apps/starter 3.0: POSIX shell script and function to schedule commands
sys-apps/systemd-tmpfiles-openrc 1: openrc init-files for systemd-tmpfiles from sys-apps/systemd
sys-block/parted 2.4-r3: Create, destroy, resize, check, copy partitions and file systems
diff --git a/net-dns/noip-updater/noip-updater-2.1.9-r5.ebuild b/net-dns/noip-updater/noip-updater-2.1.9-r6.ebuild
index 04054457..ed8f4815 100644
--- a/net-dns/noip-updater/noip-updater-2.1.9-r5.ebuild
+++ b/net-dns/noip-updater/noip-updater-2.1.9-r6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Authors and Martin V\"ath
+# Copyright 1999-2022 Gentoo Authors and Martin V\"ath
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit readme.gentoo-r1 systemd toolchain-funcs user
+EAPI=8
+inherit readme.gentoo-r1 systemd toolchain-funcs
MY_P=${P/-updater/}
DESCRIPTION="no-ip.com dynamic DNS updater"
@@ -13,6 +13,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ~arm ~hppa ia64 ~mips ~ppc ppc64 sparc x86"
IUSE="ezipupd"
+DEPEND="ezipupd? (
+ acct-group/ez-ipupd
+ acct-user/ez-ipupd
+)"
S=${WORKDIR}/${MY_P}
@@ -53,8 +57,6 @@ src_install() {
pkg_preinst() {
use ezipupd && ! use prefix || return 0
- enewgroup ez-ipupd
- enewuser ez-ipupd -1 -1 /var/cache/ez-ipupdate ez-ipupd
if test -d /var/cache/ez-ipupdate
then chmod 750 /var/cache/ez-ipupdate
chown ez-ipupd:ez-ipupd /var/cache/ez-ipupdate
diff --git a/sys-apps/schedule/schedule-8.0.1.ebuild b/sys-apps/schedule/schedule-8.0.1-r1.ebuild
index 81f6e78d..c9fe3900 100644
--- a/sys-apps/schedule/schedule-8.0.1.ebuild
+++ b/sys-apps/schedule/schedule-8.0.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2014-2020 Martin V\"ath
+# Copyright 2014-2022 Martin V\"ath
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
RESTRICT="mirror"
-inherit readme.gentoo-r1 user systemd
+inherit readme.gentoo-r1 systemd
DESCRIPTION="script to schedule jobs in a multiuser multitasking environment"
HOMEPAGE="https://github.com/vaeth/schedule/"
@@ -28,7 +28,8 @@ RDEPEND=">=dev-lang/perl-5.12
# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
# || ( >=dev-lang/perl-5.6.0 >=virtual/perl-IO-1.190.0 )
# || ( >=dev-lang/perl-5.9.4 virtual/perl-Digest-SHA) # for encryption
-DEPEND=""
+DEPEND="acct-group/schedule
+ acct-user/schedule"
DISABLE_AUTOFORMATTING="true"
DOC_CONTENTS="It is recommended to put a lengthy passphrase into the first line
@@ -76,16 +77,12 @@ generate_password() (
)
pkg_postinst() {
- if ! use prefix
- then enewgroup schedule
- enewuser schedule -1 -1 -1 schedule
- fi
if ! test -s "${EPREFIX}/etc/schedule.password"
then if generate_password
then ewarn "You should fill ${EPREFIX}/etc/schedule.password with a random password:"
ewarn "the current random value is not necessarily cryptographically strong."
chown 'schedule:schedule' -- "${EPREFIX}/etc/schedule.password" || \
- ewarn "failed to set permissions for ${EPREFIX}/etc/schedule.password"
+ ewarn "failed to set permissions for ${EPREFIX}/etc/schedule.password"
else ewarn "failed to generate ${EPREFIX}/etc/schedule.password"
fi
fi