summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2024-07-05 22:47:17 +0200
committerMartin Väth <martin@mvath.de>2024-07-05 22:47:17 +0200
commit65710745ed1e1a36aa31f870ab408c23a9537bdf (patch)
tree0423f487d674724f4da18cc1e9cfd17b8206752e
parentapp-portage/portage-bashrc-mv: Version bump (diff)
downloadmv-65710745ed1e1a36aa31f870ab408c23a9537bdf.tar.gz
mv-65710745ed1e1a36aa31f870ab408c23a9537bdf.tar.bz2
mv-65710745ed1e1a36aa31f870ab408c23a9537bdf.zip
sys-apps/less: Version bump. media-video/luvcview: Copy from gentoo repository
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--media-video/luvcview/Manifest2
-rw-r--r--media-video/luvcview/luvcview-0.2.6-r1.ebuild45
-rw-r--r--media-video/luvcview/metadata.xml8
-rw-r--r--metadata/pkg_desc_index3
-rw-r--r--sys-apps/less/Manifest4
-rw-r--r--sys-apps/less/files/less-643-LESSOPEN-escape.patch61
-rw-r--r--sys-apps/less/files/lesspipe-r4.sh (renamed from sys-apps/less/files/lesspipe-r3.sh)11
-rw-r--r--sys-apps/less/less-661-r1.ebuild (renamed from sys-apps/less/less-643-r3.ebuild)7
8 files changed, 69 insertions, 72 deletions
diff --git a/media-video/luvcview/Manifest b/media-video/luvcview/Manifest
new file mode 100644
index 00000000..1f399648
--- /dev/null
+++ b/media-video/luvcview/Manifest
@@ -0,0 +1,2 @@
+DIST luvcview_0.2.6-4.diff.gz 8227 BLAKE2B 10c01541920b24dafd55f969f4e86daa2d4bb7d73fc33b7ed3b592e080ef31a6d4e429585402e291f20898af5d48021d618ca6496a668def767fad4dced47a3f SHA512 ae0f760e08979065a072f28367fd6c399ff8bc821b79d021d0fec8bb62e36b10804f30f708de3e23ccada0596b7c57dec6d0f8b92a777046e1bfa087686e7f87
+DIST luvcview_0.2.6.orig.tar.gz 100318 BLAKE2B 94273fc4635d515c78b9604e3a1bcdfeea5f835f64f6bb1f19c192ebee5f96b7e1d3b1e7921969560e5bd111cb7e84d20806c42b64f4ab6de40e1597ffae3c99 SHA512 6d0b480c51716e36401680ae333c37f179122d04feca3e91056f77abee6dc60dac4e431e8cca999780c343d10170678ace1eb29076c9211c0cfef6d65a4599ab
diff --git a/media-video/luvcview/luvcview-0.2.6-r1.ebuild b/media-video/luvcview/luvcview-0.2.6-r1.ebuild
new file mode 100644
index 00000000..76fab30b
--- /dev/null
+++ b/media-video/luvcview/luvcview-0.2.6-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors and Martin V\"ath
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit desktop toolchain-funcs
+
+PATCH_LEVEL="4"
+
+DESCRIPTION="USB Video Class grabber"
+HOMEPAGE="https://packages.qa.debian.org/l/luvcview.html"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/l/${PN}/${PN}_${PV}-${PATCH_LEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl
+ media-libs/libv4l
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eapply "${WORKDIR}"/${PN}_${PV}-${PATCH_LEVEL}.diff
+ eapply debian/patches/*.patch
+ sed -i -e 's:videodev.h:videodev2.h:' *.{c,h} || die
+ sed -i -e 's:-O2::' Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC) ${LDFLAGS}"
+}
+
+src_install() {
+ dobin luvcview
+ doman debian/luvcview.1
+ dodoc Changelog README ToDo
+ make_desktop_entry ${PN}
+}
diff --git a/media-video/luvcview/metadata.xml b/media-video/luvcview/metadata.xml
new file mode 100644
index 00000000..a2dfee95
--- /dev/null
+++ b/media-video/luvcview/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>media-video@gentoo.org</email>
+ <name>Gentoo Video project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 23ffc47a..9e262673 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -83,6 +83,7 @@ media-tv/sundtek-tv 221030.153539: Sundtek MediaTV Pro III Drivers
media-tv/w_scan 20170107-r1: Scan DVB-C/DVB-T/DVB-S channels
media-video/avidemux 2.7.8: Video editor designed for simple cutting, filtering and encoding tasks
media-video/avinfo 1.0_alpha15_p1-r1: Utility for displaying AVI information
+media-video/luvcview 0.2.6-r1: USB Video Class grabber
media-video/video-mv 17.3: Frontends for using mplayer/mencoder, ffmpeg/libav, or tzap as video recorder
net-dialup/accounting 1.60.45.3.1-r1: Give statistics about dialup connections. Originally part of SuSE's smpppd
net-dialup/martian-modem 20100123-r3: ltmodem alternative driver providing support for Agere Systems winmodems
@@ -97,7 +98,7 @@ net-print/foo2zjs 20200221: Support for printing to ZjStream-based printers
sci-geosciences/googleearth 7.1.8.3036-r4 7.3.0.3832-r4 7.3.4-r2 7.3.6: A 3D interface to the planet
sci-mathematics/reduce 20141130-r3 20190413: A general-purpose computer algebra system
sys-apps/cpi 3.2: A wrapper for cp -i -a, making use of diff
-sys-apps/less 643-r3: Excellent text file viewer, optionally with additional selection feature
+sys-apps/less 661-r1: Excellent text file viewer, optionally with additional selection feature
sys-apps/man 1.6g-r4: Standard commands to read man pages
sys-apps/openrc-wrapper 2.4: Use openrc init scripts with systemd or other init systems
sys-apps/paxopen 1.2: A wrapper script to set PAX kernel variables to an insecure/safe state
diff --git a/sys-apps/less/Manifest b/sys-apps/less/Manifest
index 40ed82a5..6866df87 100644
--- a/sys-apps/less/Manifest
+++ b/sys-apps/less/Manifest
@@ -1,2 +1,2 @@
-DIST less-643.tar.gz 592291 BLAKE2B 6dc60dc2e8db05afdae466877a1d26a3008ff5378bbbf2fbdf9efc4f87c0fcfde5703d44a24d4355c98d3a5f438bdb51173150f2a69f801d9c8e4a7401d71b53 SHA512 6a324ac54e22429ac652dc303bc1fe48933555d1cbf8ad7ecf345940910c014fef9551a3219743cfb7115e356b5841ae97d6ce62e7a1ba1e3300d243efca34d9
-DIST less-select-2.15.tar.gz 32374 BLAKE2B f135d80cdae38f84309754863ae3736f574e5476414b7b835a8d2f9c3ff6c8baf92ece154763e61e9f0a2133928bc8f7462b209e9508ac2dad2ca454eb32aecf SHA512 1284d11b9098cbdc5243886ffdc29cf998853fd998ef6a6e1ef8af9cdcf89175bc7573b836afaab8dc06a51e9018cdd07bc9011c994bc7fd63965d3bff46defd
+DIST less-661.tar.gz 648198 BLAKE2B c1fa9a7a646fcc1203945e00c35fe41bddef0c564e30f120a37e417ecd5c60d234e0253a2e18123508dd5c0313bce346dc7752e96cdc1b067bd07a2a39818b42 SHA512 49d81ff9e79d43ce0271490e3bffd590b4aed5fcb387bc8eb3128de99e5b5a5ede2e2818b546f6e3a140fa6261f1de3dfba1231f7ff7ef18502bb7030eaea1b5
+DIST less-select-2.16.tar.gz 32973 BLAKE2B ee2eea1e7caa772d16f41385fbd2088d30e622a090a82398b86082aba392227b6f6d552a10e95eaf300bc6dc4828d1154adec519e5914dc0a2c392a00ee050fa SHA512 acf52b77e54b1c38339f7d2dff6b7d2303ef27316ba75edcdbfb8a3e76d25f42e1363b62eabe79c62c5fbe954a58c398d4d3dc4ad037e06f125458cb3fb10149
diff --git a/sys-apps/less/files/less-643-LESSOPEN-escape.patch b/sys-apps/less/files/less-643-LESSOPEN-escape.patch
deleted file mode 100644
index f3fe50fc..00000000
--- a/sys-apps/less/files/less-643-LESSOPEN-escape.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-https://openwall.com/lists/oss-security/2024/04/12/5
-https://bugs.gentoo.org/929210
-https://github.com/gwsw/less/commit/007521ac3c95bc76e3d59c6dbfe75d06c8075c33
-
-Upstream provided this version via email as a backport to 643.
---- a/filename.c
-+++ b/filename.c
-@@ -134,6 +134,15 @@
- }
-
- /*
-+ * Must use quotes rather than escape char for this metachar?
-+ */
-+static int must_quote(char c)
-+{
-+ /* {{ Maybe the set of must_quote chars should be configurable? }} */
-+ return (c == '\n');
-+}
-+
-+/*
- * Insert a backslash before each metacharacter in a string.
- */
- public char * shell_quote(char *s)
-@@ -164,6 +173,9 @@
- * doesn't support escape chars. Use quotes.
- */
- use_quotes = 1;
-+ } else if (must_quote(*p))
-+ {
-+ len += 3; /* open quote + char + close quote */
- } else
- {
- /*
-@@ -193,15 +205,22 @@
- {
- while (*s != '\0')
- {
-- if (metachar(*s))
-+ if (!metachar(*s))
- {
-- /*
-- * Add the escape char.
-- */
-+ *p++ = *s++;
-+ } else if (must_quote(*s))
-+ {
-+ /* Surround the char with quotes. */
-+ *p++ = openquote;
-+ *p++ = *s++;
-+ *p++ = closequote;
-+ } else
-+ {
-+ /* Insert an escape char before the char. */
- strcpy(p, esc);
- p += esclen;
-+ *p++ = *s++;
- }
-- *p++ = *s++;
- }
- *p = '\0';
- }
diff --git a/sys-apps/less/files/lesspipe-r3.sh b/sys-apps/less/files/lesspipe-r4.sh
index baec90dc..02a610d0 100644
--- a/sys-apps/less/files/lesspipe-r3.sh
+++ b/sys-apps/less/files/lesspipe-r4.sh
@@ -1,5 +1,5 @@
#!/bin/bash
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Preprocessor for 'less'. Used when this environment variable is set:
@@ -281,7 +281,10 @@ lesspipe() {
[nN][oO]|[nN]|0|false) LESSCOLOR=0;;
*) LESSCOLOR=1;;
esac
- if [[ ${LESSCOLOR} != "0" ]] && [[ -n ${LESSCOLORIZER=pygmentize} ]] ; then
+
+ [[ -n ${NO_COLOR} ]] && LESSCOLOR=0
+
+ if [[ ${LESSCOLOR} != "0" ]] && [[ -n ${LESSCOLORIZER=pygmentize -O style=rrt} ]] ; then
# 2: Only colorize if user forces it ...
# 1: ... or we know less will handle raw codes -- this will
# not detect -seiRM, so set LESSCOLORIZER yourself
@@ -301,7 +304,7 @@ if [[ $# -eq 0 ]] ; then
elif [[ $1 == "-V" || $1 == "--version" ]] ; then
cat <<-EOF
lesspipe (git)
- Copyright 1999-2023 Gentoo Authors
+ Copyright 1999-2024 Gentoo Authors
Mike Frysinger <vapier@gentoo.org>
(with plenty of ideas stolen from other projects/distros)
@@ -314,7 +317,7 @@ elif [[ $1 == "-h" || $1 == "--help" ]] ; then
Usage: lesspipe <file>
lesspipe specific settings:
- LESSCOLOR env - toggle colorizing of output (no/yes/always; default: no)
+ LESSCOLOR env - toggle colorizing of output (no/yes/always; default: yes)
LESSCOLORIZER env - program used to colorize output (default: pygmentize)
LESSIGNORE - list of extensions to ignore (don't do anything fancy)
diff --git a/sys-apps/less/less-643-r3.ebuild b/sys-apps/less/less-661-r1.ebuild
index 62013910..991a6bfc 100644
--- a/sys-apps/less/less-643-r3.ebuild
+++ b/sys-apps/less/less-661-r1.ebuild
@@ -9,8 +9,8 @@ inherit autotools flag-o-matic optfeature toolchain-funcs
DESCRIPTION="Excellent text file viewer, optionally with additional selection feature"
PATCHN="less-select"
-PATCHV="2.15"
-PATCHVER="633"
+PATCHV="2.16"
+PATCHVER="661"
PATCHRUMP="${PATCHN}-${PATCHV}"
PATCHBALL="${PATCHRUMP}.tar.gz"
SELECTDIR="${WORKDIR}/${PATCHRUMP}"
@@ -38,7 +38,6 @@ BDEPEND="test? ( virtual/pkgconfig )"
PATCHES=(
"${FILESDIR}"/${PN}-643-lesstest-pkg-config.patch
- "${FILESDIR}"/${PN}-643-LESSOPEN-escape.patch
)
pkg_setup() {
@@ -90,7 +89,7 @@ src_install() {
keepdir /usr/lib/lessfilter.d
keepdir /etc/lessfilter.d
- newbin "${FILESDIR}"/lesspipe-r3.sh lesspipe
+ newbin "${FILESDIR}"/lesspipe-r4.sh lesspipe
if use original-gentoo
then a="-R -M --shift 5"